Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Whenever I try to run executable files (.exe. .com, .bat, ...) on a mapped network drive I get this annoying popup dialog asking me if I'm sure. How to stop this and just run the files unimpeded?

"the publisher cannot be verified" dialog
(not my screenhot, just an image I grabbed at random online)

Unlike the related Get rid of "The Publisher could not be verified. Are you sure you want to run this software"? I don't want to disable this safety feature completely (as in "don't ever warn me about any executable"), just turn it off for known good locations.

share|improve this question
up vote 12 down vote accepted

An easier and safer option (suggested by matt wilkie in the comments) (Source)

This is the result of Microsoft trying to protect users from malicious programs. The message will appear for any shortcut or executable that is hosted on a network share.

To resolve the issue, follow the below steps:

  1. First, determine what server the shortcut is hosted on.

  2. Open Internet Explorer.

  3. Click Tools, then Internet Options.

  4. Click the ‘security’ tab. Once you are on this tab. Make sure you first click "Local Intranet", and then the "Sites" button. Click it.

  5. On the form that is displayed, click ‘Advanced’.

You will be shown a list of sites that are in the "Local Intranet"

  1. To add your server to the list. Type file://server where 'server' is the name of your server, Click ‘Add’.

  2. Click OK, on the rest of the dialogs to get out of the settings for Internet Explorer.

share|improve this answer
thanks Clay. I'd intended to write it up as an answer myself, but didn't have the time right then. The problem became solved, so of course I promptly forgot about it. ;-) – matt wilkie Jan 24 '12 at 6:33
This is it. This is a lifesaver on a computer lab system with my network drive attached. I run a series of scripts and executables each day when I log on, and having to select "yes, run anyway" got so obnoxious. – bgStack15 Aug 12 '14 at 12:59

You may have to remove a stream attribute/file that is attached to your program you downloaded from the Internet. Microsoft adds that for your own protection.

  1. Check for alternate data streams on the file by running dir /r:

    C:\Program Files\eclipse>dir /r eclipse.exe
     Directory of C:\Program Files\eclipse
    18/11/2013  09:45 PM           319,488 eclipse.exe
                                        26 eclipse.exe:Zone.Identifier:$DATA
        ︙        ︙                  ︙       ︙

    If you see that Zone.Indentifier stream file attached to your downloaded file, you'll have to remove it.

  2. Download streams.exe from Microsoft.

  3. Run it on your program (e.g., eclipse.exe) as follows:

    C:\Program Files\eclipse>streams.exe -d *.exe
    Streams v1.56 - Enumerate alternate NTFS data streams
    Copyright (C) 1999-2007 Mark Russinovich
    Sysinternals -
    C:\Program Files\eclipse\eclipse.exe:
    Deleted :Zone.Identifier:$DATA
    C:\Program Files\eclipse\eclipsec.exe:
    Deleted :Zone.Identifier:$DATA
    C:\Program Files\eclipse>
  4. Message gone.

share|improve this answer
This is a local solution for a local problem. Disabling a GPO at large like other suggest is not a good idea and usually not possible in a corporate environment. Another way would be to copy the file to a USB stick (FAT32) and back. – ixe013 Apr 1 '14 at 15:23
Definitely +1 as this fixed my problem. I first tried How to Unblock a File to Stop "Open File - Security Warning" and "Windows 8 SmartScreen" Prompt but the fix wasn't available until I ran dir -r foo.exe and found the Zone.Identifier version of the executable. – Greg Burghardt Nov 14 '14 at 13:58
This is a good solution as it fixes the problem with the trusted putty.exe without compromising security for other, unknown programs. – markus_b Feb 4 at 10:49

Go to Internet Options > Security Tab > Local Intranet zone > Custom Level button

Scroll down to "Launching applications and unsafe files"

set it to enabled, hit OK.

You may have to do this for the Internet zone also.


enter image description here

share|improve this answer
thanks. that got me looking in the right direction, and I found a simpler solution: add the server(s) to the Intranet zone trusted sites as `file://server' (ref) – matt wilkie Sep 29 '11 at 5:18
Yep , much safer solution. – Moab Sep 29 '11 at 21:44

Worked for me ... Move the exe file to a non-ntfs volume (e.g. a USB flash drive (FAT)), then move it back again.

IT seems to be something to do with an NTFS property in the .exe file, which FAT does not have. So moving to a FAT drive removes it, and when moved back the propoerty is gone!.


share|improve this answer
type old.exe >new.exe

this worked for me

share|improve this answer
For the curious, this works because it copies only the actual file's data, not the alternate data stream that contains the zone identifier. – Ben N Jan 21 at 0:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .