Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm working from a template someone else provided for me. In the "Styles and Formatting" window are a number of useful styles such as "Outline 1", "Outline 2", etc.

If I click in a piece of text in a slide, the corresponding item in the "Styles and Formatting" window is highlit, as I would expect.

How do I select one of these styles and apply it to the text I'm editing? I thought double-clicking on a style name would work as it does for OpenOffice Writer, but nothing happens.

What am I missing?

share|improve this question
add comment

migrated from stackoverflow.com Sep 29 '11 at 11:03

This question came from our site for professional and enthusiast programmers.

1 Answer

up vote 2 down vote accepted

The styles concept in Impress is different from that implemented in Writer. There are presentation styles applying to "structural elements" of your presentation on the one hand and graphics styles applying to graphics objects on the other.

Which presentation style is applied depends on the type of the object. For example, the "outline" styles are applied to the different outline entries, and the applied style depends on the level of each single outline entry. So, to "apply" another presentation style you will have to modify the outline level, e.g. by simply increasing the level using TAB.

The same is true for the "Notes" presentation style: It will be applied automatically if you add notes using the "Notes" page of your Impress presentation.

This means: you can't simply select one of the presentation styles to modify the layout of the content. Instead, you could insert and use drawing objects using the Drawing Toolbar. For example, if you want to insert some code samples on different styles with consistent layout, you could insert text boxes using the drawing toolbar and define a Graphics Style, selecting a monospaced font and some nice background/border. That graphics style can be applied manually to different drawing objects as usual.

Of course, you can modify the presentation styles to change the style of every "outline 3" entry, for example.

share|improve this answer
    
That helps somewhat, but doesn't solve everything. I'd already noticed that using the arrow buttons to demote or promote outline entries was changing the indentation and the bullet, but the font size is remaining the same. E.g.: I'm at outline 1. I start a new item by hitting return. I hit tab. The font, indentation, and bullet change to outline 2, but the font size remains the same. –  Edward Falk Sep 29 '11 at 18:05
    
Hmmm; looks like I've simply stumbled on a bug. I can modify a style and change any attribute I want except the font size. Changing it has no effect. For now, I'll settle for manually setting the font size for every item. –  Edward Falk Sep 29 '11 at 18:41
    
@Edward: Very strange. I've just tested modifying the font size of some of the "Outline" Styles, and everything works fine. I'm working with OpenOffice 3.2 and LibreOffice 3.4.3. So i don't think it's a bug. It's more likely that your presentation has "hard formatting" applied, so the style definitions won't be effective. You will have to reset the hard formatting first before changes of the styles definitions will be visible. Just select the Outline view, hit CTRL+A to select the complete text, and select Default Formatting from the Format menu. –  tohuwawohu Sep 29 '11 at 20:01
    
I have no idea what "hard formatting" is, but your suggestion worked! –  Edward Falk Sep 29 '11 at 21:13
    
@Edward: great, i'm happy that it worked! BTW: "hard formatting" means assigning style elements (font, font size, bold/italics) not using styles but directly, using the "Styles and Formatting" toolbar, for example. "Soft formatting" is using styles and templates. Text with "hard formatting" won't change on changes of the Paragraph Style, since hard formatting overrides soft formatting. So, you had to remove the "hard formatting" before the Style definitions got visible. –  tohuwawohu Sep 30 '11 at 7:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.