Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I had auto-hide chosen for a long time but today it stopped hiding though the option is still checked off under Properties. I tried unchecking, re-checking; pressing Apply; pressing Ok numerous times but the taskbar won't hide. What went wrong?

Oh, it's Win 7 64-bit.

share|improve this question
1  
Have you tried turning it off and on again? –  Ian Pugsley Sep 29 '11 at 21:26
    
I can't right now. In the middle of working with 70 windows etc. –  verve Sep 29 '11 at 21:53
    
So is your question "How to fix it", or "What went wrong to cause this"? –  techie007 Sep 29 '11 at 23:31
    
What is causing it so that I can fix it. grin –  verve Sep 30 '11 at 0:26
2  
Perhaps you should save your work and try rebooting. It's often pretty hard to pin down problems like this, and a fresh start would be helpful in determining the issue. –  nhinkle Sep 30 '11 at 5:18
add comment

5 Answers

Try this: Run the Task Manager (CTRL+SHIFT+ESC).Stop the Explorer process. If there are multiple explorers running, sort them by memory usage and stop the largest one. Alternatively, just stop them all. With task manager open, go to File > New Task (Run…) and type:

C:\Windows\explorer.exe

Now retry auto-hiding.

share|improve this answer
    
I've also found this thread. It may be helpful: answers.microsoft.com/en-us/windows/forum/windows_7-desktop/… - Check out the 3rd answer on that page. –  Mehper C. Palavuzlar Sep 29 '11 at 21:32
    
I was going to try this and then I noticed another problem: my mouse cursor stays on top of VLC player that always never had the cursor on top of the program as the app has an "always on top" option (which I always have had selected) but when the taskbar problem started this began too. Does this change the cause of the autohide thing? –  verve Sep 30 '11 at 0:23
    
@verve: I don't know if it is related but stopping & restarting explorer is an easy method you may try. The link I gave in my above comment has also different methods you may try. –  Mehper C. Palavuzlar Sep 30 '11 at 7:22
    
Be sure only to end that process. Any others, and your computer might be toast. –  HelpingHand May 30 '13 at 14:11
add comment

I've had that happen under two circumstances:

  1. When there is a message in the notification area of the task bar that wants to be clicked on. Clicking on the message resolved it in this case.

  2. Occasionally when I've had the Network and Sharing Center Open, I have to re-open and close the Network and Sharing Center in order to get the task bar to hide.

Neither of these makes much sense to me, but I have fix the problem several times this way.

share|improve this answer
add comment

Canceling Explorer.exe works for a while, but a permanent fix is to respond to those icons in the taskbar--usually an update, and usually flashing. You have to do this each time a new one tries to get your attention.

share|improve this answer
    
Welcome to SU. There's no need to add your name as a signature, SU does that for you. –  dav May 30 '13 at 14:34
add comment

I tried as Mehper C. Palavuzlar suggests, and killed/restarted explorer.exe, which fixed the problem.

The issue happens to me all the time so I wanted to find a "clean way" do this to ensure that none of my work gets lost. Here's the resource I used with a good detailed explanation: How to Terminate and Restart Explorer.exe Process Cleanly in Windows 7...

share|improve this answer
add comment

Are there any messages of Windows that you have still not solved?

If Windows send any message, the Taskbar will be at top until you take an action.

For example:

  • Windows Defender is outdated
  • Windows Updates available
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.