Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I live on a campus that provides Internet access through squid http proxy. We need to authenticate to access the Internet. This means that I can login from only one machine at a time and cannot access Internet from multiple machines using same login ID. I devised a workaround to this problem. I installed another squid proxy server on one of my machines A that is always on and has a static local IP. Now I could configure my other machines to use this proxy instead without any authentication and thus I was able to achieve what I wanted.

However, after some time I started getting problems on my machine A. Internet connection became really slow and would often disconnect. Other machines accessing Internet through this machine would often get Proxy is refusing connections on firefox. Now I don't know if the two things are related and I'd like to find out.

Also I'd like to find out how can I debug this issue ?

(I am using Ubuntu 11.04)

share|improve this question

migrated from stackoverflow.com Sep 30 '11 at 12:28

This question came from our site for professional and enthusiast programmers.

    
@Ken White : Should I delete it form here and repost it in superuser ? Because it is taking too much time for move. –  AnkurVj Sep 29 '11 at 15:18
    
Hang on a few. I'll flag it for the moderators to look at; maybe we can get it moved faster. –  Ken White Sep 29 '11 at 17:15

1 Answer 1

"Other machines accessing Internet through this machine would often get Proxy is refusing connections on firefox"

Often? That's odd, the error suggests the IP:proxy you're trying to connect is not listening so... It can only mean the wrong port was typed or squid process is really not running!

Maybe the process is "dying" at some point, make sure its running and tail (-f) cache.log to see if you're getting any errors!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.