Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Sony Ericsson C702 phone with a flat fee internet subscription (GPRS/UMTS). I'd like to connect my Linux (Kubuntu 9.04) laptop to internet via this phone, using bluetooth (I also have a cable connection but that's propietary, doubt it'll work). How can I do this, preferably via GUI / NetworkManager / the BT applet that comes with KDE?

In Windows I use SE's PC suite software which works great, but is not available for Linux.

share|improve this question
    
Please add the sony-ericsson tag (superuser.com/questions/tagged/sony-ericsson). –  Johan Sep 4 '09 at 9:34

4 Answers 4

up vote 1 down vote accepted

If you are fine with using your USB cable instead of Bluetooth, you can (this works on my K800i, assuming SE didn't remove this option) go to Connectivity Settings -> USB -> USB Internet. There select the data account you use to access internet from the phone and turn it on. Now your phone will work as a usb network adapter when you plug it in. I imagine NetworkManager should see it immediately, althought I configured in manually "the Debian way". The name of the interface was usb0 in my case.

This was by far the easiest way to configure it, you reuse your phones Internet settings so you don't have to input all these settings on your PC.

EDIT: Re. the Debian way, I added the following to /etc/network/interfaces

# Phone internet connection
allow-hotplug usb0
iface usb0 inet dhcp

So dhcp worked fine for me.

share|improve this answer
    
I have connected the phone and usb0 shows up. I make a new connection for it in knetworkmanager (setting it to dhcp) but if I try to connect it will just keep running but not succeed. What can be wrong and what is "the debian way"? Networking in Linux freaks me out a bit –  Bart van Heukelom Sep 3 '09 at 0:12
    
Hi, I use dhcp as well so I am not sure what didn't work with Network Manager. Worth trying to set up manually. Kubuntu should have very similar network stack as Debian. –  Grzenio Sep 4 '09 at 7:11
    
Magically works now –  Bart van Heukelom Sep 4 '09 at 11:58
    
Glad to hear it. –  Grzenio Sep 12 '09 at 19:38

There's a guide for setting up bluetooth dialup at Ubuntu help site: https://help.ubuntu.com/community/BluetoothDialup

share|improve this answer
    
But I'm not looking for dialup. My phone has a permanent "broadband" (or so they call it) internet connection –  Bart van Heukelom Sep 2 '09 at 12:57
    
@Bart - You still need to "dial up" to initiate the connection –  Sathya Sep 2 '09 at 14:11
    
I don't think so, at least not in the way you mentioned. My internet settings in the phone do not have a phone number listed anywhere. –  Bart van Heukelom Sep 3 '09 at 0:11
    
Admittedly I'm not an expert on this, but I think you do need to use dialup. The "dialup" here is really confusing concept. You're not actually dialling to any actual number of the ISP, rather you're "dialling up" to the phone's GPRS internet connection system. This is done by dialling to a special number that the phone interprets as an internal code (such as *99#). That's how I've always connected to the broadband internet on my phone, in fact even right now. It boggles the mind and feels gimmiky, sure, but that's ultramodern mobile broadband technology for you. :) –  Ilari Kajaste Sep 3 '09 at 5:10
1  
It works, though not via bluetooth. I used the dialup interface that appears when using the USB cable –  Bart van Heukelom Sep 4 '09 at 9:31

The USB cable you have is not propietary, your phone will show up as a normal USB CDC WMC device, with two serial ports available, /dev/ttyACM0 and /dev/ttyACM1. Those ports should can be used for normal dial-up.

share|improve this answer

I'm using Arch Linux with KDE but it should also work for you: Use Blueman (an alternative Bluetooth Applet/Manager which is way better, than the buildin) ot connect your phone Dial-In Bluetooth port to and rfcomm device and use wvdial (or in my case: pywvdial) to dial in.

For details (lie wvdial configuration for your provider) you need to google ;)

share|improve this answer
    
I have installed blueman but cannot connect. I can add the phone to the list of devices, but I try to use it as network access point, it'll say "Connecting" for a while, then fail. –  Bart van Heukelom Sep 3 '09 at 0:13
    
Ok, so I managed to get a "Success!" when connecting to the network access point (by first connecting to serial) but then how do I connect to the network? I don't get an extra interface or something. –  Bart van Heukelom Sep 4 '09 at 8:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.