Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have got Ubuntu 11.04 installed on a machine that has two ethernet cards. I am able to connect to the network on either of the cards.

But I am facing a problem: For some reason the network is not working properly. For example a lot of ping packets are lost. This is not happening for any other machine on the network. I have changed the network cable to no avail which leads me to believe that perhaps this is a software problem.

How do I debug this problem?

I am getting as much as 31% packet loss and it is driving me crazy! Any ideas?

Okay the situation has changed :

I was using xmonad earlier and therefore couldn't use the network icon that shows up in the standard gnome-interface. Now when I logged into the gnome desktop, I could see the icon. I clicked on it, it showed me something called Auto Ethernet. I clicked on it, got connected. I don't have any packet losses anymore.

How do I connect to this so called "Auto eth0" from my terminal ?? How do I connect to any connection ? From terminal I was trying to do ifup on an interface and didnt work ! How did gnome do it ? What commands is it running that I am unable to run from my terminal !

share|improve this question
Where are you pinging to and from? Inside the LAN? Also, when you say "disconnects frequently" are you referring to the packet loss, or does the interface go down? – sblair Sep 30 '11 at 15:20
Just the packet loss. Yes I am pinging inside the lan only. Now I have done something and it isnt getting any IP. On trying ifup it says "Unknown interface eth0=eth0" and same for eth1 as well – AnkurVj Sep 30 '11 at 15:25
I dont have any entries in /etc/networking/interfaces. Should I have any – AnkurVj Sep 30 '11 at 15:26
At what hop are you seeing the packet loss? – MaQleod Sep 30 '11 at 15:34
up vote 1 down vote accepted

I would suggest checking and updating the drivers for your NICs. Also, you may have a hardware problem with the NICs themselves. Do you drop pings on both NICs? If you have an extra available NIC you could try swapping them out to see if that fixes the issue. Also try pinging the loopback address (, what do those pings look like?

If you are connected to a switch then another possiblity could be a bad port on the switch, you may want to try changing ports. Hope this helps!

share|improve this answer
yes I drop pings on both NICs. loopback pings are 0% loss. I did change the ports but to no avail. Somehow now I have also changed the rules on etc/udev/rules.d/70-persistent something and I just want to restore all settings. As of now, I am not able to connect to the network through either lan port – AnkurVj Sep 30 '11 at 15:31
Well it doesn't sound like a hardware issue since your loopback is working, so my next thought would be that there is an issue with the drivers for the NICs. I would try reinstalling the NICs from scratch. Do you have a backup copy of the d70-presistent rule file, or do you know what the values used to be set to? It looks like this file is usually used in cases like yours where you have multiple NICs so that the cards are assigned the same device names when you reboot. – Dan Sep 30 '11 at 16:32
I'm thinking it likely has something to do with the fact that you removed the rules for the two NICs. The purpose for that file is for managing multiple NICs. I think if you physically uninstall one of the NICs and remove the driver, then reboot, it will probably remove that error message. I think the error message is just saying that it is ignoring the NIC that you are not using to connect to the network with, which must be set as eth0. However, "if it ain't broke don't fix it" may apply here. Glad to hear it's working for you now! – Dan Sep 30 '11 at 17:46
Check the following link for instructions on removing that error.… – Dan Sep 30 '11 at 17:49
You'd need to physically remove the NIC from the machine, you may also need to uninstall it from Ubuntu. However, that process will probably be unnecessarily time consuming. I would sugest following the instructions at the following link, and just leaving your hardware setup the way it is, as long as your getting a network connection and not getting an error, you're golden. If you'd still like to remove the device anyway and would like more detailed instructions let me know. Heres the link:… – Dan Sep 30 '11 at 18:00

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.