Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running firefox 7 on windows 7 having continuously upgraded according to their schedule. Since I upgraded to 7, it randomly pegs my CPU and I have to manually kill the process. This is nuts! Any thoughts? Am I the only one?

UPDATE: what happens is that I'll have several tabs open and then it pegs the cpu. I have to manually kill it with process explorer. When I go to start it up again, it asks which tabs to open. If I select all, I get the same result. Before anyone suggests it's a problem with a specific web page - know that I have tried many different combinations of pages - including only wikipedia pages.

UPDATE 2: I installed a fresh firefox in another directory. I have disabled all add-ons and plugins and the problem still persists.

UPDATE 3: I created another profile with no add-ons or extensions. It worked (for a while). Then I started adding back add-ons and extensions and the problem occurred again. So I disabled EVERYTHING and the problem persists.

share|improve this question
    
Does this happen regardless of the page loaded? What if you only have one tab open to about:blank? –  Shinrai Sep 30 '11 at 15:10
    
seems to be somewhat dependent on the page but I've seen it happen on several different pages. –  andersonbd1 Sep 30 '11 at 15:17
    
I switched to Opera after Firefox 6. Starting with Firefox 4 I started having crazy performance issues on all 3 of my machines. No troubles with Opera. I commented with this because it doesn't answer your question and I don't know the answer. A guess is that they may be changing things too fast with their new release schedule and it's allowing bugs and memory leaks back in. Also, JavaScript may be the source of your problems also. –  Ryan Clarke Sep 30 '11 at 15:21
    
In the past I've had similar problems with FireFox plugins (Acrobat was a culprit but Flash might be another) - I'd try disabling them, uninstalling them or using something like FlashBlock. At least as a way to eliminate them from suspicion. –  RedGrittyBrick Sep 30 '11 at 15:43
    
Yeah, I asked specifically because my guess would be it's a plugin or something. Disable everything and see what happens. –  Shinrai Sep 30 '11 at 15:47
show 2 more comments

3 Answers

up vote 1 down vote accepted
+100

Re-install Winblowz ;p works for me every time ;)

share|improve this answer
add comment

Try creating a new profile (firefox.exe -profilemanager) and seeing if it still happens in that profile.

It probably won't.

Then start customizing it to make it like your current profile, and see what causes the problem.

share|improve this answer
1  
Killer answer. This will solve the problem. –  gd1 Oct 3 '11 at 18:17
    
tried this with no success. –  andersonbd1 Oct 4 '11 at 12:35
1  
@andersonbd1: Your post says It worked (for a while). Then I started adding back add-ons and extensions and the problem occurred again. IMHO, that is success! Now you know it's caused by your extensions, so you can figure out which one is causing it. Make a new profile, add them one-by-one, and see which one caused it -- that's the entire point of this method! –  Mehrdad Oct 4 '11 at 20:23
add comment

Try restarting Firefox in safe mode (all addons/plugins are automatically disabled) and see if it functions normally. If it does, it means one of your addons is to blame for the CPU hogging.

share|improve this answer
    
tried it. same result. I'll add more detail to the issue –  andersonbd1 Oct 3 '11 at 17:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.