Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using PowerPoint 2007 and have pasted in a table from Excel 2007. When I paste it in it automatically becomes a PowerPoint table, and looks fine. However, everything is quite squashed together, so I would like to add some cell padding. Using the standard options on the dropdown menu (Layout > Alignment > Cell Margins), e.g. "Normal", works fine but makes the table a bit too big (it goes over the edge of the page). So, I would like to set custom margins of 0.13cm (left/right) and 0.07cm (top/bottom). When I do this (using "Custom Margins"), the text in all of the cells becomes centered!

This would be fine if the alignment was actually changed to Center, but it is not! It remains as it was before (left in some cells, right in others). Can anyone tell me what is happening and how to correct it? Is it a bug?

Update: Screenshots and solution

I have prepared some screenshots to clarify the problem. Whilst preparing them, I found the answer. It turns out that you need to select an option in the "Vertical alignment" dropdown of the custom cell margins dialog box. Selecting the "Middle" option produces the desired result.

The images show:

  • what it looks like immediately after pasting;

    enter image description here

  • after using the Normal setting of the Cell Margins dropdown:

    enter image description here

  • If instead I select Custom Margins and specify 0.13cm (L/R), 0.07cm (top/bottom). Note that the horizontal alignment setting is Left for the selected cell (the one saying "Company A", near the top left of the table). Note also that the vertical alignment is not showing any of the three options as selected

    enter image description here

  • what the dialog looks like which appears when you click on Custom Margins

    enter image description here

  • If you select Middle in the Vertical alignment setting, you get the desired result.

    enter image description here

share|improve this question
    
Perhaps I'm misunderstanding the problem, but if you add left/right padding to a cell, same amount on both sides, it's going to make the space available for the text to "pour" into centered within the cell. The text will retain its left/center/right alignment relative to the available block of space but the block of text as a whole will be centered within the cell. If that describes what you're seeing, it's not a bug, it's the way text block margins work. If this is about something else, could you post a couple of pictures, before and after adjustment, of what you're seeing? –  Steve Rindsberg Oct 1 '11 at 16:38
    
@SteveRindsberg: Thanks for your comment. Indeed, what you say makes good sense! Unfortunately that's not how it behaves though :) I've added some screenshots to illustrate. I also have a sample file I can share if there is a good way of doing that (there doesn't seem to be an option for attachments). Happily, whilst preparing the screenshots, I also found the (rather silly IMHO) solution! (See above.) –  Michael Pavey Oct 3 '11 at 9:40
    
Thanks for the set of illustrations; still, I can't reproduce this here. What I'm seeing is that cells copy/pasted from Excel retain whatever vertical alignment they were assigned in Excel, at least where there's an equivalent in PPT. I'd be happy to have a look at a set of example XLSX/PPTX files though ... email to steve at-sign pptools dot com. Also, in case it matters, I'm on SP2 of Office 2007. –  Steve Rindsberg Oct 3 '11 at 14:54
    
Hmm, well I solved the main issue I'm pleased to say! Are you referring to the secondary issue I noted in my third bullet point? (Not so much an issue as an observation really.) I will email through my sample Excel file in case you'd like to explore further! Thanks again. –  Michael Pavey Oct 3 '11 at 16:19
    
Thanks for sending the files. I'll have a peek at them when I get a few free minutes and get back with you here if I learn anything new or at least useful. ;-) –  Steve Rindsberg Oct 4 '11 at 14:15
add comment

2 Answers 2

Selecting any "Vertical alignment" from Top, Middle, or Bottom gets the desired result. Note that this workaround is still necessary in PowerPoint 2010.

share|improve this answer
    
It's also necessary in PowerPoint 2013. –  ComFreek Apr 3 at 18:17
add comment
up vote 0 down vote accepted

It turns out that you need to select an option in the "Vertical alignment" dropdown of the custom cell margins dialog box. Selecting the "Middle" option produces the desired result.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.