Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Recently, I upgraded to Mozilla 6.0.2 , on Win-7 Professional x64 on my laptop. I am facing this pesky problem that whenever I begin typing in Mozilla - be it in Address bar, or typing some things in a field on some web site, or even when I was typing this question, in between the cursor automatically moves to some other position in the window and whatever I am typing gets entered at a wrong location, where it is not intented. If I don't look at screen, then it just enters the text at incorrect place, which I have to delete and click at write place(usually the end of the sentence) and type again.

Other I guess related behavior while typing text, some text got automatically selected and when I typed the next letter, that all got deleted and was replaced by the new letter.

And no, I made sure I am not accidentally touching any part of the touch pad of laptop.

This particular behavior does not appear while I type in a)Microsoft Word b)Visual C++ 2010 IDE source files c) Any other text editor.

This is really annoying me. Not only the problem, but what could be its cause?

Could this be really related to Mozilla as I doubt or something else on Windows?

Is there any Firefox setting which could be causing this?

EDIT:

Somehow doubt it's got to do with my touchpad sensor driver or something. Recently I had to reinstall my OS due to Win-7 professional edition, and maybe there are no proper drivers for the touchpad. Earlier I used to see HP pre-installed Mousepad control menu in the tray. This seems to be some prickly bigger/non-browser related problem. Any pointers from experts. Please help.

share|improve this question
    
Not a specific answer to your question, but is it possible for you to upgrade to firefox 7? If so does the behaviour continue? –  Matthew Steeples Sep 30 '11 at 18:44

2 Answers 2

  1. As Matthew mentioned, try upgrading to Firefox 7 first.

  2. If that doesn't work, try this:

Firefox advanced options screenshot

If that doesn't work, try starting Firefox in safe mode. If it functions normally in safe mode, it means one of your addons/plugins is the source of your problems.

share|improve this answer
1  
Thanks. Disabled the two options youu showed. Tried firefox in normal mode. Same issues were seen. Then restarted firefox in 'Safe mode', even then this annoying behavior didn't go away:(. Will try updating to Firefox 7. It's really getting to nerves. –  goldenmean Oct 1 '11 at 9:22
    
Just noticed this behavior even in Internet Explorer. Somehow doubt it's got to do with my touchpad sensor driver or something. Recently I had to reinstall my OS due to Win-7 professional edition, and maybe there are no proper drivers for the touchpad. Earlier I used to see HP pre-installed Mousepad control menu in the tray. This seems to be some prickly bigger/non-browser related problem. Any pointers from experts. Please help. –  goldenmean Oct 1 '11 at 14:23
up vote 0 down vote accepted

Ok. This behavior was indeed related to my Touchpad driver going awry. The reason for that was, after reinstall of the OS to Win-7, many of the devices did not have original drivers installed by me. My bad! .Since it did not have a specialized touchpad driver(In this case synaptics) but a generic driver maybe from Windows-7 OS. Because of this, when I had a external mouse connected to the laptop, the laptop touchpad was doing alkinds of pesky things which i pointed out in the problem. After I installed the drivers specific to this touchpad device for my laptop, and put a setting that when a external mouse is detected, disable the touchpad, this behavior has gone and life is good again!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.