Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I would like to disable "Confirm Form Resubmission" popups on Google Chrome when I make a refresh. This (very) old discussion acknowledges the problem but doesn't provide a fix.

Is there someone out there with a genius idea?

share|improve this question
3  
Download the Chrome source code and hack together your own version with all the features you do and don't want. –  Moab Oct 1 '11 at 0:26
    
Like JSZ said in the discussion thread that Justin linked to, it is up to the site to handle re-visits (such as searches), not the browser to (impossibly) guess what is or is not a valid/safe automated resubmit. –  Synetech Jan 9 '12 at 6:18

3 Answers 3

up vote 7 down vote accepted
+25

Chrome introduced this "feature" in order to avoid users unintentionally duplicating POST actions on forms, such as buying the same article twice.

This apparently was fixed some time ago by using the -disable-prompt-on-repost parameter on the Chrome invocation, but this also was broken in later versions.

In spite of numerous related Chrome bug reports, that stayed open for years (!), the bug is still there. Apparently, the Chrome module that does back/forward is written so badly that it is almost impossible to fix. And nobody dares rewrite it from scratch.

Therefore, if you cannot modify the page containing the POST operation, then you are out of luck and there is no solution.

If you can modify the page, then you have two solutions :

  1. Use GET instead of POST
  2. Use the Post/Redirect/Get method with the HTTP 303 response code

There is of course the solution of using another browser than Chrome (but that doesn't answer the question).

share|improve this answer
    
Thanks. Could you please link to some of these bug reports? –  Randomblue Jan 3 '12 at 20:34
1  
Just use this google query that gives more than 8000 answers. –  harrymc Jan 4 '12 at 6:43
    
Technically, Chrome did not introduce this feature, it has been present in pretty much all web browsers for years (at least 15 or so). –  Synetech Jan 9 '12 at 6:18
    
Opera fortunately does not have this misfeature. –  cweiske Dec 7 '12 at 15:51

The flag mentioned by @harrymc works like a charm with Chrome 25.0.1364.152 (Linux).

On Linux just run the Chrome like this:

google-chrome -disable-prompt-on-repost
share|improve this answer

Try the following:

  • click on your Start menu
  • right-click on Chrome
  • click on "Internet Properties"
  • click on "Contents" and then "Settings"
  • tick every box that is in there, especially the feeds box and the form box
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.