Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Possible Duplicate:
Cannot end Windows 7 process, even tried pskill

I have always been a fan of Windows but lately on multiple occasions including skype32.exe and Microsoft Lync I have been unable to kill these processes using task manager all the command line tips I have read in other posts and no luck.

This is more principle than anything else how can it be that as a user I can't be able to kill a process, is this a bug in Windows or the apps I'm running. I would think Windows would have full control over killing a process. any help would be appreciated, it tends to happen more often than not with Skype.exe.

share|improve this question

migrated from Sep 30 '11 at 21:14

This question came from our site for professional and enthusiast programmers.

marked as duplicate by Moab, Nifle, random Oct 7 '11 at 2:34

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

There are numerous ways of preventing process killing. Most of them have to do with rootkits - that is under normal conditions you should be able to kill every process (apart from the system ones which are absolutely necessary) but in case when you are infected with some virus which includes a rootkit component this might prove more of a challenge than anything else. But in the same sense there are numerous ways of killing a process but most of them require some sort of programming tinkering. As a suggestion I'd say to try Process Explorer which is a lot powerful than task manager

share|improve this answer

All these solutions are penny wise, pound foolish.

You need to specify the error you get. That way the root cause can be solved. Merely killing the process does nothing, since a trivial background process can just relaunch the process etc etc. But I don't think that is the case.

I think the case is simpler. I assume you've done uninstalls? Have you located the file that the process is loading from? All these are important information. Merely killing the process over and over again only waste time.

share|improve this answer

Download PS tools, copy "pskill" to the System32 folder.

then use the command line to kill the process.

pskill 1680

1680 represents the process ID (PID) of the process you are trying to terminate, which can be found using task manager.

If pskill does not work, see this method

share|improve this answer

Try Process Hacker, as described at my other answer here.

I found Process Hacker is able to kill privileged / protected processes that neither of Task Manager nor Process Explorer could properly "take care of" . :-)

One of Process Hacker's advertised features is "Powerful process termination that bypasses security software and rootkits."

share|improve this answer
does not work. It says "Unable to terminate Skype.exe. An attempt was made to access an existing process" – sydd Oct 6 '13 at 13:32

Not the answer you're looking for? Browse other questions tagged or ask your own question.