Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Once in a while, when I try to open a spreadsheet in Excel 2010 that's on a mapped drive, I get the error message "The network is busy. Try again later." I can retry the open right away a second time and it works.

Is there some way I can get rid of this annoyance? Also, is there some underlying problem with the file server or the network that might have other negative effects?

I'm running Windows 7, and the file share I'm connecting to is on a Samba server on a Linux box.

share|improve this question

1 Answer 1

You might want to ask this on server fault... but here is what I would suggest. look at your Samba server's logs. You may be receiving errors in there. One thing that come to mind is a setting for Oportunistic Locking (or oplock). You may need to tune the ser4ver if it reports errors in the logs.

BTW, this is a very old problem for non MS servers dealing with MS clients. I remember back when people used Netware 4.11 and who either had to choose either locked files and poor performance, or risk data corruption...

share|improve this answer
    
I can't see anything in the smb.log that looks like a locking error around the time this happened on the client. I was asking here because I was hoping that I could do something about this on the client machine. –  rakslice Oct 2 '11 at 6:41
    
you could try the following: Open a command prompt with Admin rights. Run the following command. netsh interface tcp set global autotuning=disabled –  cwheeler33 Oct 3 '11 at 15:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.