Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to run the ToDoList (any version from 5.3 to 6.2) in linux (ubuntu 11.04)

I've tried to use under wine 1.2 and 1.3 without success:
   1 - I've downloaded the program (todolist_exe.zip);
   2 - unpacked it;
   3 - and use the "Open with Wine Windows Program loader";
   4 - the mouse cursor starts thinking and stops after a few seconds and nothing happens.

I've also search the net for help but still haven't found a solution.

After I used the command line "wine ToDoList.exe" it gave me:

wine: cannot find L"C:\\windows\\system32\\plugplay.exe"
err:module:import_dll Library MFC42u.DLL (which is needed by L"Z:\\home\\user_name\\Progs\\todolist\\ToDoList.exe") not found
err:module:LdrInitializeThunk Main exe initialization for L"Z:\\home\\user_name\\Progs\\todolist\\ToDoList.exe" failed, status c0000135

Please help :)

share|improve this question
    
Open it up in your terminal, cd to that directory, and run wine todolist_exe.zip. It gives more verbose output that way. (The WINE people haven't, as far as I know, developed a good logging system yet. Then again, I don't use WINE, so don't quote me on that) –  new123456 Oct 1 '11 at 1:01
    
sorry, I'm just not used to the command line. I've done it now and reedit the question adding the command line error. –  Seeker Oct 4 '11 at 8:34
    
TDL's developer posted some links that might be helpful. –  Ian Dunn May 20 '12 at 22:41

2 Answers 2

The MFC42u.dll library is a Visual C++ runtime library that does not come by default with WINE.

winetricks should be able to get the script for you.

#!/bin/bash
wget http://winetricks.org/winetricks
EXE="winetricks"
chmod +x $EXE
$EXE vcrun2005
$EXE vcrun2008

Put the above script somewhere (your home directory, preferably), and make it executable. Run it, and it should be able to get winetricks for you, as well as the VC++ runtime redistributable libraries.

share|improve this answer
    
I've run that and it installed, but it didn't fix my problem. The error messages are the same. –  Seeker Oct 10 '11 at 21:32
    
I've also tried to run it from a saved folder in a windows partition (instead of my current of linux) and the result is the same. –  Seeker Oct 10 '11 at 21:32
1  
later I've tried to run "winetricks vcrun6" (not shure what it does) that i saw in a forum and finally i was able to run the toDoList.exe using wine (the program must be in a windows partition) –  Seeker Oct 10 '11 at 23:43
    
I tried this. The program option wizard opened - and then crashed when it was time to load the software –  Tal Galili Nov 21 '11 at 7:46
    
Installing winetricks and running winetrucks vcrun6 fixed the MFC42u.DLL error for me too. Note that it requires the cabextract package to be installed first. If you don't have it the winetricks vcrun6 install will fail, and you'll have to delete your ~/.wine directory before running winetricks vcrun6 again. –  Ian Dunn May 28 '12 at 0:42

ToDoList will still crash with some big or complicated lists. The following works for me

$ winetricks vcrun6 comctl32
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.