Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to connect to a remote computer with Nvidia Tesla M2070q GPU. I am trying to put the device in TCC mode with this: nvidia-smi -g 0 -dm 0 but gives me the following error: Failed to initialize NVML: Uknown Error

The remote computer has two graphic cards, Nvidia Tesla M2070q and some ATI. Other information: I can't open Nvidia control panel via remote desktop, it gives me the following error message: You are not currently using a display attached to an NVIDIA GPU

How can I overcome this?

share|improve this question

migrated from stackoverflow.com Oct 1 '11 at 2:16

This question came from our site for professional and enthusiast programmers.

1 Answer 1

Remote desktop uses a virtual graphics driver so the control panel is not accessible. You would need to log in directly. It is not done by the control panel anyway.

This is what I have done. Run a CMD window as Administrator -- right click to launch run as Administrator. CD to C:\Program Files\NVIDIA Corporation\NVSMI. Run nvidia-smi.exe with no arguments to see what the command arguments are. Use -q to query the status. Use -dm to toggle TCC mode. Use separate argument -i to target a specific device. The setting is tentative. Reboot to make it permanent.

Once the TCC settings are in place, you should be able to launch programs from remote desktop that will access the TCC mode driver.

share|improve this answer
    
What was your second attached display ? on that remote server it has an ATI attached to display. will this be an issue ? because doing the step above from local stand Still with the same error –  ZeroCool Sep 29 '11 at 16:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.