Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Update

Basically @NoUsername's contribution solved my issue. But I found it a bit tricky to actually "override" the JavaScript, the key problem is that the configuration page reloads quite frequently. So I'll leave just a few notes how I achieved this on Chrome:

  1. on the wlan configuration page I opened Chrome developer console.
  2. There I was able to open frame "wlan_config.asp" (or similar name) - this contains just the configuration window without any navigation (this page would not reload automatically)
  3. after making the settings in the configuration frame, instead of clicking ok - call apply_submit(); in the JavaScript console. This will submit all settings without checking them! (so be careful!)

I set up my home network all through this 3G wifi router. Problem is it only allows 5 devices to connect. That's not much especially if a wifi printer and gaming consoles keep hogging these slots. On the other hand I don't see the point on blocking these devices. They are (should) not doing anything online just intern in my network.

The documentation I can find is surprisingly unhelpful and focuses how to plug the device in a power socket.

So what would be my options.

Notes: I have already been able to get a shell on the device using ssh. It's running some Busybox. But I fail to find the how and where this limit is enforced/created.

Notes 2: Specifically my device is a 3WebCube - unfortunately not specifically marked with the Huawei Model number.

Successes so far

After enabling ssh in the options I can login:

ssh -T admin@3.home

admin@3.home's password: 
-------------------------------
-----Welcome to ATP Cli------
-------------------------------

unfortunately because of this -T - the tab key does not work for autocomplete and all inputted commands will be echoed. Also no history with arrow keys.

ATP interface

this custom interface is not very useful:

ATP>help

help
Welcome to ATP command line tool.
If any question, please input "?" at the end of command.

Shell

BUT undocumented - I somehow found on a auto translated chinese website - all you need to do is input sh

ATP>sh
sh


BusyBox vv1.9.1 (2011-03-27 11:59:11 CST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

# 

using tftp after installing tftp on my desktop I was able to send files with

tftp -s -l curcfg.xml  192.168.1.103

and to download onto the huawei with

tftp -g -r curcfg.xml  192.168.1.103

I think I'll need that - because I don't see any editor installed.

readout stuff

(still playing around where I would get interesting info)

For confirmation of hardware:

# cat /var/log/modem_hardware_name
^HWVER:"WL1B153M001"# 

# cat /var/log/modem_software_name
1096.11.03.02.107 
# cat /var/log/product_name
B153

An interesting observation I recently made. Using a range extender WN3000RP I was able to connect some additional devices when they were "denied" at the router. Correction This only worked for a short time - now I see that ALL devices - also connected to extender count as one.

share|improve this question
    
I picked up that the limit might be related with the vlan configuration. But I fail to find anything in the documentation - can anyone confirm that? –  bdecaf Nov 29 '11 at 15:35
    
What is iptables config ? Does this article relate to the problem ? –  harrymc Feb 20 '12 at 8:53
    
I will check it. But the limit of 5 devices seems so extremely low - I doubt it's because the router runs out of ports. It reminds me on android - but couldn't figure out how they enforce this limit. –  bdecaf Feb 20 '12 at 13:03
    
Anything useful in iptables config ? –  harrymc Feb 21 '12 at 12:13
    
I added the output. I don't see anything suspicious. –  bdecaf Feb 22 '12 at 20:47

4 Answers 4

up vote 2 down vote accepted

I know this question is quite old and probably of no more interest to the author, but maybe somebody else may stumble over this via a web search just like i did, so i wanted to share my findings.

I actually have 2 of these WebCubes, one which is newer, does not have this 5 device limit, the older one did. I was able to change this configuration and it also persisted restarts.

The way i did it was completely different, i only used the web administration interface. My version displays a field there which says something like "maximum number of devices" (not literally), this can be found somewhere in the wifi settings. When i entered something bigger than 5, i think it was immediately reset by some javascript, as far as i remember, or at least it was reset when you submitted these changes. So i dug in the JavaScript code of the site (with Chromes dev utils, which you get when pressing F12), and found that the submit method of the HTML form had this code somewhere which changes the value back to max. 5. I tried to change that and it sort-of-worked, the problem is that there is also some kind of ajax thing going on which constantly does some reloading and somehow messes with these manual edits, but after some trial and error, i was able to time it or stop it somehow, that it worked and it really submitted the other value (i think i set it to 10). After that it showed 10 when i visited that page (have not dared to touch it since).

I guess this could also be done via curl or some similar utility, but because of the javascript stuff that happens when submitting the page and cookies etc., i thought it would be easier this way.

Sorry that i can't give any more detailed info, but it's really some time since i did that and i currently don't have access to this device to look for any specifics.

As said before, this worked on the older version of my 3WebCube, since the newer one came with a 10 device limit by default, i haven't tried it there.

share|improve this answer
    
Oh - this is still a great question for me. I will try it as soon I'm home. –  bdecaf Jun 19 '12 at 8:19
    
Just to report back. I tried your approach - but it didn't work for me. Unfortunately I can't tell is it due to a different firmware - or me just not understanding JS as well. –  bdecaf Jul 9 '12 at 9:32
    
I got it as described. Just a few notes as I had problems getting it to work. I went to the page Advanced>WLAN>WLAN-Basis Settings. There I opened Chrome>View>Developer Tools. In this I searched the file: wlan_cfg.js . In lines 97 and 99 i replaced the 5 with 50. Then I copied the whole script and used Java Script Injector to inject it on the page. After all this I was able to input the number 15 as max allowed clients - and it still is there after reboot. Now I'll test it... –  bdecaf Aug 12 '12 at 11:39
    
First test indicates I have now 8 clients connected. So I'll accept this answer. –  bdecaf Aug 12 '12 at 12:24

It seems like the file defaultcfg.xml that you have posted is very promising indeed. It looks like some sort of an XML configuration file.

You could play with it, but assure first that you have the means to reinitialize the router back to its initial state. If it cannot boot then it is just a nice brick.

I would put my money on the XML tag starting with <WLANConfigurationInstance InstanceID="1". While there are four such with increasing InstanceID numbers, the first is the only one of the four that has Enable="1". I notice also that one of the parameters is X_AssociateDeviceNum="5". Now I wonder what would happen if you carefully increased this to X_AssociateDeviceNum="6" (don't jump the gun with too-large changes and save a local and remote backup copy of the file).

As regarding finding an integrated text editor, you could try for the old and true ed or for sed.

One should also hope that this file is not generated from other files during the boot. If the above change doesn't solve anything and the file reverts after a reboot, and if find and/or grep are installed, you could recursively search the entire file-system for files named "*WLAN*Config*" (case insensitive) or grep for WLANConfig.

share|improve this answer
    
Oh yes that also seems good. My key problem is - To make the modifications I need to restart some process. I can not alter the file permanently (yet I hope) - but so reboot is not useful. And unfortunately the busybox documentation is very vague. –  bdecaf Feb 23 '12 at 22:03
    
You can see by the date on the file if it is really regenerated at boot. You will need to reboot the router to be sure that the modification "took". The name defaultcfg.xml might also mean that this is the default configuration to be used when you revert to "factory settings". You will have to try and see. –  harrymc Feb 24 '12 at 7:04

Sorry posting this as answer - couldn't add the code to the question as it would be over the max allowed size.


Contents of /etc

wscd.conf             root.pem              handy_rsa_key
upnp                  rf.conf               handy_dss_key
sysmsg                resolv.conf           group
simplecfgservice.xml  profile               fstab
share.map             passwd                ethertypes
services              operator_list.res     dhcps2.leases
serverkey.pem         lmhosts               dhcps.leases
servercert.pem        inittab               dhcps.conf
samba                 init.d                defaultcfg.xml
rsa_host_key          inetd.conf            bootfile.txt

contents of defaultcfg.xml

<?xml version="1.0" ?>
<InternetGatewayDeviceConfig>
<InternetGatewayDevice>
<DeviceInfo ProvisioningCode="">
<X_PortalManagement Enable="0" PortalUrl-Computer="" PortalUrl-STB="" PortalUrl-Phone=""/>
<X_ServiceManage FtpEnable="1" FtpUserName="ftp" FtpPassword="ftp" FtpPort="21" FtpPath="/mnt" TelnetEnable="1" TelnetPort="23" SambaEnable="0"/>
<X_PlmnProfile NumberOfInstances="1">
<X_PlmnProfileInstance InstanceID="1"  X_PLMN_ID="22299" X_ProfileName="Drei AT"/>
</X_PlmnProfile>
</DeviceInfo>
<ManagementServer URL="http://hcms.huawei.com" Username="hgw" Password="hgw" PeriodicInformEnable="1" PeriodicInformInterval="7200" ConnectionRequestUsername="acs" ConnectionRequestPassword="acs" PeriodicInformTime="" X_SSLCertEnable="0" X_BindInterface="" KickURL="" UpgradesManaged="1" DownloadProgressURL="" ManageableDeviceNotificationLimit="0" UDPConnectionRequestAddressNotificationLimit="0" STUNEnable="0" STUNServerAddress="" STUNServerPort="3478" STUNUsername="handy" STUNPassword="handy" STUNMaximumKeepAlivePeriod="90" STUNMinimumKeepAlivePeriod="30" X_ConnReqPort="8081">
</ManagementServer>
<Time Enable="0" NTPServer1="" NTPServer2="" NTPServer3="" NTPServer4="" NTPServer5="" LocalTimeZoneName="GMT+8" X_Label="-1"/>
<UserInterface>
<X_Web Timeout="5" Language="de">
<UserInfo NumberOfInstances="2">
<UserInfoInstance InstanceID="1"  Username="admin" Userpassword="admin">
<ObjExtention>
<Userpassword HideBits="27"/>
</ObjExtention>
</UserInfoInstance>
<UserInfoInstance InstanceID="2"  Username="user" Userpassword="user"/>
</UserInfo>
</X_Web>
<X_Cli>
<UserInfo NumberOfInstances="2">
<UserInfoInstance InstanceID="1"  Username="admin" Userpassword="admin" Userlevel="0"/>
<UserInfoInstance InstanceID="2"  Username="user" Userpassword="user" Userlevel="1"/>
</UserInfo>
</X_Cli>
</UserInterface>
<X_SyslogConfig Enable="0" Level="Debug" DisplayLevel="Error" LogServerEnable="0" MainServer="" MainServerPort="514" MinorServer="" MinorServerPort="514"/>
<X_Security MacFilterNumberOfEntries="0" MacFilterPolicy="0" MacFilterRight="1" IpFilterInNumberOfEntries="0" IpFilterInRight="0" IpFilterOutNumberOfEntries="0" IpFilterOutPolicy="0" IpFilterOutRight="1" X_FirewallGeneralLevel="2" X_UrlFilterNumberOfEntries="0" X_UrlFilterEnabled="1" X_UrlFilterPolicy="0" X_ICMPRight="0">
<WhiteUrlFilter NumberOfInstances="0"/>
<WhiteMacFilter NumberOfInstances="16">
<WhiteMacFilterInstance InstanceID="1" SourceMACAddress=""/>
<WhiteMacFilterInstance InstanceID="2" SourceMACAddress=""/>
<WhiteMacFilterInstance InstanceID="3" SourceMACAddress=""/>
<WhiteMacFilterInstance InstanceID="4" SourceMACAddress=""/>
<WhiteMacFilterInstance InstanceID="5" SourceMACAddress=""/>
<WhiteMacFilterInstance InstanceID="6" SourceMACAddress=""/>
<WhiteMacFilterInstance InstanceID="7" SourceMACAddress=""/>
<WhiteMacFilterInstance InstanceID="8" SourceMACAddress=""/>
<WhiteMacFilterInstance InstanceID="9" SourceMACAddress=""/>
<WhiteMacFilterInstance InstanceID="10" SourceMACAddress=""/>
<WhiteMacFilterInstance InstanceID="11" SourceMACAddress=""/>
<WhiteMacFilterInstance InstanceID="12" SourceMACAddress=""/>
<WhiteMacFilterInstance InstanceID="13" SourceMACAddress=""/>
<WhiteMacFilterInstance InstanceID="14" SourceMACAddress=""/>
<WhiteMacFilterInstance InstanceID="15" SourceMACAddress=""/>
<WhiteMacFilterInstance InstanceID="16" SourceMACAddress=""/>
</WhiteMacFilter>
<BlackMacFilter NumberOfInstances="16">
<BlackMacFilterInstance InstanceID="1" SourceMACAddress=""/>
<BlackMacFilterInstance InstanceID="2" SourceMACAddress=""/>
<BlackMacFilterInstance InstanceID="3" SourceMACAddress=""/>
<BlackMacFilterInstance InstanceID="4" SourceMACAddress=""/>
<BlackMacFilterInstance InstanceID="5" SourceMACAddress=""/>
<BlackMacFilterInstance InstanceID="6" SourceMACAddress=""/>
<BlackMacFilterInstance InstanceID="7" SourceMACAddress=""/>
<BlackMacFilterInstance InstanceID="8" SourceMACAddress=""/>
<BlackMacFilterInstance InstanceID="9" SourceMACAddress=""/>
<BlackMacFilterInstance InstanceID="10" SourceMACAddress=""/>
<BlackMacFilterInstance InstanceID="11" SourceMACAddress=""/>
<BlackMacFilterInstance InstanceID="12" SourceMACAddress=""/>
<BlackMacFilterInstance InstanceID="13" SourceMACAddress=""/>
<BlackMacFilterInstance InstanceID="14" SourceMACAddress=""/>
<BlackMacFilterInstance InstanceID="15" SourceMACAddress=""/>
<BlackMacFilterInstance InstanceID="16" SourceMACAddress=""/>
</BlackMacFilter>
<IpFilterIn NumberOfInstances="0"/>
<AclServices HTTPLanEnable="1" HTTPWanEnable="0" TELNETLanEnable="1" TELNETWanEnable="0" FTPLanEnable="0" FTPWanEnable="0" SSHLanEnable="0" SSHWanEnable="0" HTTPSLanEnable="1" HTTPSWanEnable="0"/>
</X_Security>
<Layer3Forwarding X_AutoDefaultGatewayEnable="0" X_DefaultGatewayIPAddress="" DefaultConnectionService="">
</Layer3Forwarding>
<LANDevice NumberOfInstances="1">
<LANDeviceInstance InstanceID="1"  X_WLANEnable="1">
<LANHostConfigManagement DHCPServerEnable="1" MinAddress="192.168.1.100" MaxAddress="192.168.1.150" ReservedAddresses="" DNSServers="" DomainName="3.home" IPRouters="" DHCPLeaseTime="86400" UseAllocatedWAN="" AssociatedConnection="" PassthroughLease="60" PassthroughMACAddress="">
<DHCPConditionalServingPool NumberOfInstances="4">                              
<ObjExtention MaxInstanceNum="4"/>                                              
<DHCPConditionalServingPoolInstance InstanceID="1"  Enable="1" MinAddress="0.0.0.0" MaxAddress="0.0.0.0" VendorClassID="STB" X_DeviveDhcpRelay="0"/>
<DHCPConditionalServingPoolInstance InstanceID="2"  Enable="1" MinAddress="0.0.0.0" MaxAddress="0.0.0.0" VendorClassID="Phone" X_DeviveDhcpRelay="0"/>
<DHCPConditionalServingPoolInstance InstanceID="3"  Enable="1" MinAddress="0.0.0.0" MaxAddress="0.0.0.0" VendorClassID="Camera" X_DeviveDhcpRelay="0"/>
<DHCPConditionalServingPoolInstance InstanceID="4"  Enable="1" MinAddress="0.0.0.0" MaxAddress="0.0.0.0" VendorClassID="Computer" X_DeviveDhcpRelay="0"/>
</DHCPConditionalServingPool>                                                   
<IPInterface NumberOfInstances="1">
<IPInterfaceInstance InstanceID="1"  Enable="0" IPInterfaceIPAddress="192.168.1.1" IPInterfaceSubnetMask="255.255.255.0" IPInterfaceAddressingType="DHCP" X_RouteProtocolRx="Off" X_RIPOperation="Active"/>
</IPInterface>
</LANHostConfigManagement>
<LANEthernetInterfaceConfig NumberOfInstances="4">
<ObjExtention MaxInstanceNum="4"/>
<LANEthernetInterfaceConfigInstance InstanceID="1"  Enable="1">
</LANEthernetInterfaceConfigInstance>
<LANEthernetInterfaceConfigInstance InstanceID="2"  Enable="0">
</LANEthernetInterfaceConfigInstance>
<LANEthernetInterfaceConfigInstance InstanceID="3"  Enable="0">
</LANEthernetInterfaceConfigInstance>
<LANEthernetInterfaceConfigInstance InstanceID="4"  Enable="0">
</LANEthernetInterfaceConfigInstance>
</LANEthernetInterfaceConfig>
<WLANConfiguration NumberOfInstances="4">
<WLANConfigurationInstance InstanceID="1"  SSIDAdvertisementEnabled="1" Enable="1" MaxBitRate="Auto" Channel="6" AutoChannelEnable="1" RegulatoryDomain="IT" SSID="SSID-1" BeaconType="WPA" MACAddressControlEnabled="1" Standard="b/g/n" WEPKeyIndex="1" WEPEncryptionLevel="104-bit" BasicEncryptionModes="WEPEncryption" BasicAuthenticationMode="None" WPAEncryptionModes="TKIPEncryption" WPAAuthenticationMode="PSKAuthentication" IEEE11iEncryptionModes="AESEncryption" IEEE11iAuthenticationMode="PSKAuthentication" WMMEnable="0" X_Wlan11NTxRxStream="1" X_MixedEncryptionModes="AESEncryption" X_MixedAuthenticationMode="PSKAuthentication" X_PowerValue="20" X_AssociateDeviceNum="5" X_WlanMacFilterpolicy="0" X_WlanStaWakeEnable="0" X_WlanIsolateControl="0" X_Wlan11NBWControl="20/40">
<WPS Enable="1" X_WPSMode="ap-pin" DevicePassword=""/>
<X_WlanMacFilter NumberOfInstances="16">
<X_WlanMacFilterInstance InstanceID="1" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="2" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="3" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="4" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="5" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="6" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="7" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="8" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="9" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="10" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="11" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="12" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="13" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="14" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="15" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="16" X_WlanSrcMacAddress=""/>
</X_WlanMacFilter>
<X_BridgeRestriction NumberOfInstances="4">
<X_BridgeRestrictionInstance InstanceID="1" X_WlanBridgeMacAddress="" X_WlanBridgeStatus="0"/>
<X_BridgeRestrictionInstance InstanceID="2" X_WlanBridgeMacAddress="" X_WlanBridgeStatus="0"/>
<X_BridgeRestrictionInstance InstanceID="3" X_WlanBridgeMacAddress="" X_WlanBridgeStatus="0"/>
<X_BridgeRestrictionInstance InstanceID="4" X_WlanBridgeMacAddress="" X_WlanBridgeStatus="0"/>
</X_BridgeRestriction>
<WEPKey NumberOfInstances="4">
<WEPKeyInstance InstanceID="1"  WEPKey="1111111111111"/>
<WEPKeyInstance InstanceID="2"  WEPKey="2222222222222"/>
<WEPKeyInstance InstanceID="3"  WEPKey="3333333333333"/>
<WEPKeyInstance InstanceID="4"  WEPKey="4444444444444"/>
</WEPKey>
<PreSharedKey NumberOfInstances="1">
<PreSharedKeyInstance InstanceID="1"  PreSharedKey="abcdedfg"/>
</PreSharedKey>
</WLANConfigurationInstance>
<WLANConfigurationInstance InstanceID="2"  SSIDAdvertisementEnabled="1" Enable="0" MaxBitRate="Auto" Channel="6" AutoChannelEnable="1" RegulatoryDomain="IT" SSID="SSID-2" BeaconType="WPAand11i" MACAddressControlEnabled="1" Standard="b/g/n" WEPKeyIndex="1" WEPEncryptionLevel="104-bit" BasicEncryptionModes="WEPEncryption" BasicAuthenticationMode="None" WPAEncryptionModes="TKIPEncryption" WPAAuthenticationMode="PSKAuthentication" IEEE11iEncryptionModes="AESEncryption" IEEE11iAuthenticationMode="PSKAuthentication" WMMEnable="0" X_Wlan11NTxRxStream="1" X_MixedEncryptionModes="AESEncryption" X_MixedAuthenticationMode="PSKAuthentication" X_PowerValue="20" X_AssociateDeviceNum="5" X_WlanMacFilterpolicy="0" X_WlanStaWakeEnable="0" X_WlanIsolateControl="0" X_Wlan11NBWControl="20/40">
<WPS Enable="0" X_WPSMode="ap-pin" DevicePassword=""/>
<X_WlanMacFilter NumberOfInstances="16">
<X_WlanMacFilterInstance InstanceID="1" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="2" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="3" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="4" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="5" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="6" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="7" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="8" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="9" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="10" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="11" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="12" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="13" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="14" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="15" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="16" X_WlanSrcMacAddress=""/>
</X_WlanMacFilter>
<X_BridgeRestriction NumberOfInstances="4">
<X_BridgeRestrictionInstance InstanceID="1" X_WlanBridgeMacAddress="" X_WlanBridgeStatus="0"/>
<X_BridgeRestrictionInstance InstanceID="2" X_WlanBridgeMacAddress="" X_WlanBridgeStatus="0"/>
<X_BridgeRestrictionInstance InstanceID="3" X_WlanBridgeMacAddress="" X_WlanBridgeStatus="0"/>
<X_BridgeRestrictionInstance InstanceID="4" X_WlanBridgeMacAddress="" X_WlanBridgeStatus="0"/>
</X_BridgeRestriction>
<WEPKey NumberOfInstances="4">
<WEPKeyInstance InstanceID="1"  WEPKey="1111111111111"/>
<WEPKeyInstance InstanceID="2"  WEPKey="2222222222222"/>
<WEPKeyInstance InstanceID="3"  WEPKey="3333333333333"/>
<WEPKeyInstance InstanceID="4"  WEPKey="4444444444444"/>
</WEPKey>
<PreSharedKey NumberOfInstances="1">
<PreSharedKeyInstance InstanceID="1"  PreSharedKey="abcdedfg"/>
</PreSharedKey>
</WLANConfigurationInstance>
<WLANConfigurationInstance InstanceID="3"  SSIDAdvertisementEnabled="1" Enable="0" MaxBitRate="Auto" Channel="6" AutoChannelEnable="1" RegulatoryDomain="IT" SSID="SSID-3" BeaconType="WPAand11i" MACAddressControlEnabled="1" Standard="b/g/n" WEPKeyIndex="1" WEPEncryptionLevel="104-bit" BasicEncryptionModes="WEPEncryption" BasicAuthenticationMode="None" WPAEncryptionModes="TKIPEncryption" WPAAuthenticationMode="PSKAuthentication" IEEE11iEncryptionModes="AESEncryption" IEEE11iAuthenticationMode="PSKAuthentication" WMMEnable="0" X_Wlan11NTxRxStream="1" X_MixedEncryptionModes="AESEncryption" X_MixedAuthenticationMode="PSKAuthentication" X_PowerValue="20" X_AssociateDeviceNum="5" X_WlanMacFilterpolicy="0" X_WlanStaWakeEnable="0" X_WlanIsolateControl="0" X_Wlan11NBWControl="20/40">
<WPS Enable="0" X_WPSMode="ap-pin" DevicePassword=""/>
<X_WlanMacFilter NumberOfInstances="16">
<X_WlanMacFilterInstance InstanceID="1" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="2" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="3" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="4" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="5" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="6" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="7" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="8" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="9" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="10" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="11" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="12" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="13" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="14" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="15" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="16" X_WlanSrcMacAddress=""/>
</X_WlanMacFilter>
<X_BridgeRestriction NumberOfInstances="4">
<X_BridgeRestrictionInstance InstanceID="1" X_WlanBridgeMacAddress="" X_WlanBridgeStatus="0"/>
<X_BridgeRestrictionInstance InstanceID="2" X_WlanBridgeMacAddress="" X_WlanBridgeStatus="0"/>
<X_BridgeRestrictionInstance InstanceID="3" X_WlanBridgeMacAddress="" X_WlanBridgeStatus="0"/>
<X_BridgeRestrictionInstance InstanceID="4" X_WlanBridgeMacAddress="" X_WlanBridgeStatus="0"/>
</X_BridgeRestriction>
<WEPKey NumberOfInstances="4">
<WEPKeyInstance InstanceID="1"  WEPKey="1111111111111"/>
<WEPKeyInstance InstanceID="2"  WEPKey="2222222222222"/>
<WEPKeyInstance InstanceID="3"  WEPKey="3333333333333"/>
<WEPKeyInstance InstanceID="4"  WEPKey="4444444444444"/>
</WEPKey>
<PreSharedKey NumberOfInstances="1">
<PreSharedKeyInstance InstanceID="1"  PreSharedKey="abcdedfg"/>
</PreSharedKey>
</WLANConfigurationInstance>
<WLANConfigurationInstance InstanceID="4"  SSIDAdvertisementEnabled="1" Enable="0" MaxBitRate="Auto" Channel="6" AutoChannelEnable="1" RegulatoryDomain="IT" SSID="SSID-4" BeaconType="WPAand11i" MACAddressControlEnabled="1" Standard="b/g/n" WEPKeyIndex="1" WEPEncryptionLevel="104-bit" BasicEncryptionModes="WEPEncryption" BasicAuthenticationMode="None" WPAEncryptionModes="AESEncryption" WPAAuthenticationMode="PSKAuthentication" IEEE11iEncryptionModes="AESEncryption" IEEE11iAuthenticationMode="PSKAuthentication" WMMEnable="0" X_Wlan11NTxRxStream="1" X_MixedEncryptionModes="AESEncryption" X_MixedAuthenticationMode="PSKAuthentication" X_PowerValue="20" X_AssociateDeviceNum="5" X_WlanMacFilterpolicy="0" X_WlanStaWakeEnable="0" X_WlanIsolateControl="0" X_Wlan11NBWControl="20/40">
<WPS Enable="0" X_WPSMode="ap-pin" DevicePassword=""/>
<X_WlanMacFilter NumberOfInstances="16">
<X_WlanMacFilterInstance InstanceID="1" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="2" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="3" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="4" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="5" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="6" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="7" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="8" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="9" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="10" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="11" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="12" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="13" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="14" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="15" X_WlanSrcMacAddress=""/>
<X_WlanMacFilterInstance InstanceID="16" X_WlanSrcMacAddress=""/>
</X_WlanMacFilter>
<X_BridgeRestriction NumberOfInstances="4">
<X_BridgeRestrictionInstance InstanceID="1" X_WlanBridgeMacAddress="" X_WlanBridgeStatus="0"/>
<X_BridgeRestrictionInstance InstanceID="2" X_WlanBridgeMacAddress="" X_WlanBridgeStatus="0"/>
<X_BridgeRestrictionInstance InstanceID="3" X_WlanBridgeMacAddress="" X_WlanBridgeStatus="0"/>
<X_BridgeRestrictionInstance InstanceID="4" X_WlanBridgeMacAddress="" X_WlanBridgeStatus="0"/>
</X_BridgeRestriction>
<WEPKey NumberOfInstances="4">
<WEPKeyInstance InstanceID="1"  WEPKey="1111111111111"/>
<WEPKeyInstance InstanceID="2"  WEPKey="2222222222222"/>
<WEPKeyInstance InstanceID="3"  WEPKey="3333333333333"/>
<WEPKeyInstance InstanceID="4"  WEPKey="4444444444444"/>
</WEPKey>
<PreSharedKey NumberOfInstances="1">
<PreSharedKeyInstance InstanceID="1"  PreSharedKey="abcdedfg"/>
</PreSharedKey>
</WLANConfigurationInstance>
</WLANConfiguration>
<Hosts>
</Hosts>
</LANDeviceInstance>
</LANDevice>
<WANDevice NumberOfInstances="3">
<WANDeviceInstance InstanceID="1" >
<WANCommonInterfaceConfig WANAccessType="DSL" Layer1UpstreamMaxBitRate="2000000" Layer1DownstreamMaxBitRate="24000000" WANAccessProvider="HUAWEI"/>
<WANDSLInterfaceConfig Enable="1" X_ConfigMode="ALL">
<Stats>
</Stats>
</WANDSLInterfaceConfig>
<WANEthernetInterfaceConfig>
<ObjExtention HideBits="30"/>
</WANEthernetInterfaceConfig>
<X_WANUMTSInterfaceConfig>
<ObjExtention HideBits="30"/>
</X_WANUMTSInterfaceConfig>
<WANConnectionDevice NumberOfInstances="1">
<WANConnectionDeviceInstance InstanceID="1">
<WANEthernetLinkConfig>
<ObjExtention HideBits="30"/>
</WANEthernetLinkConfig>
<X_WANUMTSLinkConfig>
<ObjExtention HideBits="30"/>
</X_WANUMTSLinkConfig>
<WANDSLLinkConfig Enable="1" LinkType="EoA" DestinationAddress="PVC:8/35" ATMEncapsulation="LLC" ATMQoS="UBR" ATMPeakCellRate="0" ATMMaximumBurstSize="0" ATMSustainableCellRate="0" X_VLANIDMark="-1" X_802-1pMark="-1"/>
<WANPPPConnection NumberOfInstances="1">
<WANPPPConnectionInstance InstanceID="1"  X_LanInterface="" X_ServiceList="INTERNET" X_DHCPRelay="0" X_ProxyEnable="0" X_MAXUser="4" Enable="1" PossibleConnectionTypes="IP_Routed,PPPoE_Bridged,DHCP_Spoofed" ConnectionType="IP_Routed" name="" AutoDisconnectTime="0" IdleDisconnectTime="600" X_APN="" X_DialNumber="" NATEnabled="1" Username="123@neufpnp" Password="123" PPPAuthenticationProtocol="AUTO" MaxMRUSize="1492" DNSEnabled="1" DNSOverrideAllowed="1" DNSServers="" ConnectionTrigger="Manual" RouteProtocolRx="Off">
<X_DMZ DMZEnable="0" DMZHostIPAddress=""/>
</WANPPPConnectionInstance>
</WANPPPConnection>
</WANConnectionDeviceInstance>
</WANConnectionDevice>
</WANDeviceInstance>
<WANDeviceInstance InstanceID="2" >
<WANCommonInterfaceConfig WANAccessType="Ethernet" Layer1UpstreamMaxBitRate="100000000" Layer1DownstreamMaxBitRate="100000000" WANAccessProvider="HUAWEI"/>
<WANDSLInterfaceConfig>
<Stats>
</Stats>
<ObjExtention HideBits="30"/>
</WANDSLInterfaceConfig>
<WANEthernetInterfaceConfig Enable="1" MACAddress="" MaxBitRate="Auto" DuplexMode="Auto">
</WANEthernetInterfaceConfig>
<X_WANUMTSInterfaceConfig>
<ObjExtention HideBits="30"/>
</X_WANUMTSInterfaceConfig>
<WANConnectionDevice NumberOfInstances="1">
<WANConnectionDeviceInstance InstanceID="1">
<WANEthernetLinkConfig X_VLANIDMark="-1" X_802-1pMark="-1"/>
<X_WANUMTSLinkConfig>
<ObjExtention HideBits="30"/>
</X_WANUMTSLinkConfig>
<WANDSLLinkConfig>
<ObjExtention HideBits="30"/>
</WANDSLLinkConfig>
<WANPPPConnection NumberOfInstances="1">
<WANPPPConnectionInstance InstanceID="1"  X_LanInterface="" X_ServiceList="INTERNET" X_DHCPRelay="0" X_ProxyEnable="0" X_MAXUser="4" Enable="1" PossibleConnectionTypes="IP_Routed,PPPoE_Bridged,DHCP_Spoofed" ConnectionType="IP_Routed" name="" AutoDisconnectTime="0" IdleDisconnectTime="600" X_APN="" X_DialNumber="" NATEnabled="1" Username="123@neufpnp" Password="123" PPPAuthenticationProtocol="AUTO" MaxMRUSize="1492" DNSEnabled="1" DNSOverrideAllowed="1" DNSServers="" ConnectionTrigger="Manual" RouteProtocolRx="Off">
<X_DMZ DMZEnable="0" DMZHostIPAddress=""/>
</WANPPPConnectionInstance>
</WANPPPConnection>
</WANConnectionDeviceInstance>
</WANConnectionDevice>
</WANDeviceInstance>
<WANDeviceInstance InstanceID="3" >
<WANCommonInterfaceConfig WANAccessType="UMTS" Layer1UpstreamMaxBitRate="2000000" Layer1DownstreamMaxBitRate="8000000" WANAccessProvider="HUAWEI"/>
<WANDSLInterfaceConfig>
<Stats>
</Stats>
<ObjExtention HideBits="30"/>
</WANDSLInterfaceConfig>
<WANEthernetInterfaceConfig>
<ObjExtention HideBits="30"/>
</WANEthernetInterfaceConfig>
<X_WANUMTSInterfaceConfig Enable="1">
</X_WANUMTSInterfaceConfig>
<X_WANUMTSProfile NumberOfInstances="1">                                                                                            
<ObjExtention MaxInstanceNum="5"/>                                                                                                  
<X_WANUMTSProfileInstance InstanceID="1" ProfileName="Drei AT" APN="drei.at" DialNumber="*99#" UserName="" Password="" IPAddress="" AuthenticationProtocol="AUTO" ReadOnly="1" ConnectionTrigger="OnDemand" IdleDisconnectTime="600" MaxMRUSize="1500"/>
</X_WANUMTSProfile>                                                                                                                 
<WANConnectionDevice NumberOfInstances="1">
<WANConnectionDeviceInstance InstanceID="1">
<WANEthernetLinkConfig>
<ObjExtention HideBits="30"/>
</WANEthernetLinkConfig>
<X_WANUMTSLinkConfig Enable="1"/>
<WANDSLLinkConfig>
<ObjExtention HideBits="30"/>
</WANDSLLinkConfig>
<WANPPPConnection NumberOfInstances="1">
<WANPPPConnectionInstance InstanceID="1"  X_LanInterface="" X_ServiceList="INTERNET" X_DHCPRelay="0" X_ProxyEnable="0" X_MAXUser="4" Enable="1" PossibleConnectionTypes="IP_Routed,DHCP_Spoofed" ConnectionType="IP_Routed" name="" AutoDisconnectTime="0" IdleDisconnectTime="600" X_APN="drei.at" X_DialNumber="*99#" NATEnabled="1" Username="" Password="" PPPAuthenticationProtocol="AUTO" MaxMRUSize="1500" DNSEnabled="1" DNSOverrideAllowed="1" DNSServers="" ConnectionTrigger="OnDemand" RouteProtocolRx="Off" X_ProfileName="Drei AT">
<X_DMZ DMZEnable="0" DMZHostIPAddress=""/>
</WANPPPConnectionInstance>
</WANPPPConnection>
</WANConnectionDeviceInstance>
</WANConnectionDevice>
</WANDeviceInstance>
</WANDevice>
<Layer2Bridging>
<Bridge NumberOfInstances="1">
<BridgeInstance InstanceID="1"  BridgeName="br0">
</BridgeInstance>
</Bridge>
</Layer2Bridging>
<Services>
<X_ALGAbility H323Enable="1" SIPEnable="0" SIPPort="5060" SIPWanPath="" RTSPEnable="1" L2TPEnable="1" IPSECEnable="1" PPTPEnable="1" FTPEnable="1"/>
<X_IPTV IGMPProxyEnable="0" IGMPSnoopingEnable="1" GroupNumber="32" WanList=""/>
<X_WANBackup Mode="Disable"/>
<X_MCAST McastEnable="0" McastAddr="239.10.0.100" McastPort="37123"/>
<X_MWBAND Mode="0" TotalTerminalNumber="4" STBRestrictEnable="0" STBNumber="1" CameraRestrictEnable="0" CameraNumber="1" ComputerRestrictEnable="0" ComputerNumber="1" PhoneRestrictEnable="0" PhoneNumber="1"/>
<X_UPnP Enable="0" TR064ConfigPwd="admin"/>
</Services>
<X_SYSCONTROL SMSEnable="1" QuickUpEnable="0"/>
</InternetGatewayDevice>
</InternetGatewayDeviceConfig>

Quite to the end of the file it has the spurious <ObjExtention MaxInstanceNum="5"/> - unfortunately I can't figure out what it actually sets.

Unfortunately the busybox doesn't have any editor installed so my only way to modify the files are through ftp-ing them to my main machine, edit there and send back.

Also changes to this file do not persist a reboot - so maybe I need to modify somewhere else.

share|improve this answer

I have this device as well, but so far I haven't been able to get shell access to it.

I enabled the ssh service from the acl-configuration on the device, and tried gaining access, but can't figure out what to login with. The user admin and it's password I use for the web interface don't seem to work, and gives me the following message:

PTY allocation request failed on channel 1

I also have the full output of ssh with -vvv option on pastebin here

I think I can help if you tell me how you gained ssh access, because even though nmap does show that the dropbear daemon is running on port 22, I still haven't figured what credentials give you access to the shell.

The following steps are to be made to get to know what this limitation is about:

  • Look for the web servers running on the device by using the ps command.
  • Find the sites configuration of the server you found.
  • Look in the web interfaces code to find the section of interest for us.
share|improve this answer
    
I remember - I also had problems. If I remember right I had to set the pseudo terminal in ssh with "-t". But I'll tell you exactly when I'm back at the device. –  bdecaf Nov 25 '11 at 11:05
    
Any news? did you have to open the device at all? If I can't find the solution, I might end up taking it apart, and hoping there is a serial header on there somewhere. –  Joe R. Nassimian Nov 29 '11 at 4:07
    
Sorry was a bit busy - no I didn't have to open it. And I am able to log in via ssh through the wlan. Also I am able to get into a simple unix shell and tranfer files to and from through tftp. Basically I found out to connect on some autotranslated chinese forum. I will dig out my notes about it - hopefully today ;) –  bdecaf Nov 29 '11 at 9:31
    
ok - just put most of my notes here. Maybe you got ideas how to continue ;) –  bdecaf Nov 29 '11 at 15:36

protected by Community Jan 4 at 14:50

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.