Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Safari is almost dead on my Windows 7 64bit PC

enter image description here

I have uninstalled then re-installed the latest version but still not working.

I also followed all possible suggestion from this article. http://reviews.cnet.com/8301-13727_7-10354948-263.html

Please help.

share|improve this question
    
"Almost dead"? What does that mean? –  Otiel Oct 7 '11 at 15:43
    
You are not supplying enough information and not answering questions, so why post here ? –  harrymc Oct 10 '11 at 8:24
    
The browser opens but it doesn't open any website –  metal gear solid Oct 10 '11 at 8:39
    
Are you only having this problem in Safari? Do other browsers work? Do you have a proxy set up? –  Jannemans Oct 11 '11 at 5:29
    
Yes other browser works fine And for safari I've followed all possible fixes from this reviews.cnet.com/8301-13727_7-10354948-263.html –  metal gear solid Oct 11 '11 at 5:42

1 Answer 1

Googled around for a bit and found out that this is a fairly common problem that is spread across multiple platforms.

Apple support states that "Your DNS server(s) or your router may be affected by DNS prefetching in Safari 5.0.1 or later". This is due to Safari 5.0's DNS prefetching mechanism, which appears to send more requests than allowed by some ISPs. This issue may also cause problems with some routers.

Steps to disable DNS-prefetching:

  1. Open the run dialog with WIN+R

  2. Execute the following command (including quotes):

    "\Program Files (x86)\Common Files\Apple\Apple Application Support\defaults.exe" write com.apple.safari WebKitDNSPrefetchingEnabled -boolean false
  3. Restart Safari

To re-enable DNS-prefetching:

  1. Open the run dialog with WIN+R

  2. Execute the following command (including quotes):

    "\Program Files (x86)\Common Files\Apple\Apple Application Support\defaults.exe" delete com.apple.safari WebKitDNSPrefetchingEnabled
  3. Restart Safari

share|improve this answer
    
I tried #2 but no improvement –  metal gear solid Oct 11 '11 at 8:54
    
I follwed all steps. still doesn't work –  metal gear solid Oct 11 '11 at 9:03
    
Then I guess you're out of luck. You'll be better off running Google Chrome instead :) –  Marcus Ekwall Oct 11 '11 at 9:06

protected by Community May 7 '12 at 2:55

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.