Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a new state of the art Dell laptop with Xubuntu 11.04 on it. It has a hybrid graphics card with Optimus. The net is full of explanations why it's not working in Linux.

I was trying so much to get my NVIDIA card to work, I tried ironhide and acpi_call and nouveau but it just didn't work. See my other question here: Xubuntu 11.04 and Nvidia drivers on Dell XPS L502X

Eventually I am stuck with the Intel card. My question: Is there a way I can run Compiz Fusion on the Intel card?

If yes, how do I do it? Because now, Compiz won't work ...

Here is my lspci -vnnn | grep VGA

  00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core     Processor Family Integrated Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
  01:00.0 VGA compatible controller [0300]: nVidia Corporation Device [10de:0df4] (rev a1) (prog-if 00 [VGA controller])
share|improve this question
1  
Which intel card is it? The 3000 series? –  Simon Sheehan Oct 1 '11 at 22:52
    
I added the lspci info for the cards –  Aviv Oct 2 '11 at 7:48
add comment

1 Answer

Give BumbleBee a shot. It looks like ironhide is a port of bumblebee, but not sure what all has changed. I was messing around with this a few months ago when I had a optimus hybrid card. I was able to use Compiz with the Intel adapter while using optirun64 for applications.

https://github.com/Bumblebee-Project/Bumblebee

Did you install the nvidia_current prior to installing ironhide? I've made that mistake before and Ubuntu didn't play nice when I did end up installing Bumblebee. You may want to purge the nvidia installation and try again.

share|improve this answer
    
I tried uninstalling nvidia. didn't work. I will try uninstalling it again and then installing bumblebee (what's the different form ironhide?) –  Aviv Oct 2 '11 at 7:46
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.