Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've the following issue -

Computer A: Windows 7 Enterprise OS and part of a domain

Computer B: Windows 7 Home Premium and not part of any domain (in the default "WORKGROUP" workgroup)

I'm able to ping, RDP, tracert, and nslookup from Computer B to Computer A.

I'm not able to ping, RDP, tracert, and nslookup from Computer A to Computer B.

I'm using a Belkin wireless router that acts as the DNS (DHCP enabled). I'm able to ping the router from Computer A, which means something is blocking the traffic from the router to Computer B. I've turned off the firewall on Computer B. But, I'm still not able to connect to Computer B from Computer A.

Edit: Based on surfasb recommendations -

  1. nslookup from Computer A returns the following:

    C:>nslookup [computer_name_of_B]

    Server: UnKnown

    Address: [ip_address_router]

    Name: [computer_name_of_B].[domain_of_Computer_A]

  2. Yes, I've tried to RDP using the IP address and it fails with standard error of host not found.

  3. tracert from Computer A returns the following:

    C:>tracert [ip_address_of_computer_B]

    Tracing route to WORKGROUP [ip_address_of_computer_B] over a maximum of 30 hops:

    1 * * * Request timed out.

    2 * * * Request timed out.

Note that the nslookup appends the domain of Computer A, as Computer B is not in a domain.

share|improve this question
    
Is it the Windows built-in firewall you disabled on Computer B? –  TiCL Oct 2 '11 at 2:19
    
Yes. I'm wondering if it is because Computer A is part of a domain, while Computer B is not? –  Ar Sh Oct 2 '11 at 2:35

1 Answer 1

There are a multitude of factors.

Just off the top of my head. . .

What error does NSlookup return? Is it using NetBIOS? Or is it just failing after querying the DNS server?

What are the IP settings on each computer?

When you connect from B to A using RDP, I assume you are using the credentials "domain\user" or "user@domain", have you tried an rdp from A to B using the IP address?

When you tracert, where is it failing? Are you using the IP address or a name resolve?

In summary, please list the errors you get. Just saying they don't connect could mean anything. For all we know, a hamster fell of the wheel.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.