Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

OS: Windows 7 Home 64bit

I cannot save a large file to the root of the C drive. I am not trying to save into any folder or directory, just directly to the root.

I am using the administrator account on my home computer, and when I try saving this large file to the root of the C drive, I receive the error message:

A required privilege is not held by the client.

share|improve this question
1  
What error message do you get? Where on the C-drive are you trying to save to? –  James T Oct 2 '11 at 19:41
    
@James T: I am trying to save a file into the C drive. The file is not going into a folder. –  Dynamic Oct 2 '11 at 20:09
    
Your not getting any error message? –  James T Oct 2 '11 at 20:14
    
@James T: Sorry. It says "A required privilege is not held by the client" –  Dynamic Oct 2 '11 at 21:27
2  
perl.j apparently is trying to save into the root of the c: drive and doesn't know the terminology. –  CarlF Oct 3 '11 at 19:27

3 Answers 3

up vote 5 down vote accepted

Since Windows XP, the root directory of the system partition cannot be written to without administrator privileges. However, for security reasons, Windows Vista and Windows 7 do not grant administrator permissions by default even if logged on as an administrator unless explicitly elevated to this privilege level, which may require that you click through a UAC prompt. This is because a piece of malicious software can cause much more damage if it runs with administrator permissions than if it runs with limited user permissions.

As a result, even if you are logged in as an administrator, your program cannot write to the root directory of the C: drive as it is not given administrator permissions. To solve this problem, run the program as an administrator by right-clicking on the icon of the program and select Run as adminstrator. Note that this may require that you click through a UAC prompt. Furthermore, this can reduce your security, so do this only if this is truly necessary for a particular application.

share|improve this answer
    
But I am trying to save into the C: Drive. Not run a program. –  Dynamic Oct 3 '11 at 19:53
2  
This is not what I meant. You need to run the program that is trying to save the file with administrator privileges. For example, if the program is Microsoft Word, you need to right-click in the icon or shortcut for Word and select Run as administrator, then attempt to save the file again. –  DragonLord Oct 3 '11 at 20:08

For Windows 7:

  1. Open the Start menu
  2. Go to Control Panel → System and Security
  3. Click "Change User Account Control settings"
  4. Drag the slider down to "Never notify" to disable UAC, and click OK
  5. Restart Windows for the change to take effect

Now you should be able to copy and create files and folders on the C: drive.

share|improve this answer
    
-1: Disabling UAC greatly reduces security and is not recommended. Programs will run with administrator privileges even when they don't need it, which allows malware to easily attack the entire system. –  DragonLord Aug 21 at 20:41

Right-click-properties on your C drive in windows explorer and select the security tab, then select Administrators out of the list. Make sure Administrators have "full control" permissions.

If you click "Advanced" and go to the Owner tab, it should say "current Owner: TrustedInstaller".

If you go to the "Effective Permissions" tab, you can type in your username and check the effective permissions that your account has on the C drive.

Open up "User Accounts" from control panel and click "Change your Account Type". Make sure your account is set as Administrator.

share|improve this answer
    
Windows Home versions do not have the "Security" tab - home computer implies home version of windows OS. –  Turbo J Oct 2 '11 at 22:53
    
@Turbo J Ah yes... forgot about that. What about home premium? Don't home users have access to the security tab from safe mode anyway? –  James T Oct 2 '11 at 23:05
    
Didn't work for me. –  Dynamic Oct 2 '11 at 23:59
    
@perl.j So you can't access the security tab even when booted in safe mode? –  James T Oct 3 '11 at 1:09
    
I can access the security tab. But when I give my account permissions, I still get the same error. –  Dynamic Oct 3 '11 at 10:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.