Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an Asus Eee PC (netbook with 8" screen), running Ubuntu 10.04.

The keyboard has gone into some kind of '10-key mode', i.e. typing

  • u/U → 4
  • i/I → 5
  • o/O → 6
  • m/M → 0

It happens in all utilites for KDE desktop (word-processor, etc.) and in terminal.

I can't even type in the root password in terminal to try and see what's going on. For example, the password yields g0ht5d instead of gmhtid.

I'm pretty used to figuring these things out, but, when you can't sign-on as root, how are you going to figure it out?

share|improve this question
    
Can you connect an external keyboard and try if that works? –  slhck Oct 2 '11 at 20:54

2 Answers 2

Check that you don't have the NUM LOCK on. This is very frustrating setting!

There's going to be a [FUNCTION] key + some other key combo to toggle it on and off.

share|improve this answer
    
[CTRL]+[NUMLOCK] toggles this option. thanks for the tip. –  neal wakershauser Oct 4 '11 at 21:04

On my Asus it was the (FN) + (num lock) keys held down together.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.