Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I delete a file, it bypasses the recycle bin and is deleted permanantly.

I've made sure the recycle bin's "Don't move files to the recycle bin" option is unchecked and it has a maximum size of 25,122MB

Presumably I've changed something at some point, I had a quick google but didn't see anything obvious.

If I drag a (small) file to to the recycle bin, I see the prompt "Are you sure you want to permanently delete this file?", selecting yes deletes the file, skipping the recycle bin.

I'm using Windows 7 (32-bit), build 7100 (7100.0.x86fre.winmain_win7rc.090421-1700)

The drive the OS is installed on is an SSD using the NTFS file system.

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted
  • Have you checked the size of the size of the disk that the recycling bin is allowed to use? Might create a similar effect to deleting a large file.
  • When you drag a file over the recycling bin what text comes up? Blue 'Move to Recycling Bin or Orange Alert 'Delete'?
  • What build are you using?

Odd, my system doesn't give confirmation of either when dragged even though the box is ticked; but get confirmation on both from the keyboard.

You might wish to keep a copy of recuva until this is resolved.

share|improve this answer
    
Thanks for your answer, greyDrifter. I've checked and the blue "move to recycle bin" arrow appears, but then dropping it displays a "delete this file perm.?" dialog. I've updated my answer with build info. I've bought a copy of Win7 that'll arrive in Oct, so I think I'll use recuva until then and prob use the win dvd to do a fresh install. –  Matthew Brindley Sep 4 '09 at 23:12
add comment

It honestly sounds like your Shift key is stuck, as this is the behavior for Shift+Del.

The only other time a file will skip the recycle bin is when you delete of a network drive, or a non-NTFS drive. I am not aware of any other settings that control this behavior.

share|improve this answer
    
hehe, my shift key isn't stuck :-) I'll update my question with some drive info –  Matthew Brindley Sep 2 '09 at 12:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.