Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I really like gnu screen but there is a problem in my environment when I use it.

Examle:

username@domain:/var/www$ l
Display all 130 possibilities? (y or n)

when you click [Tab] to perform autocompletion there is a screen flashing for a very short period of time(looks like white screen but I can see it for a very-very short time).

There isn't any problems with that when I execute the same action in normal/non-screen environment.

This is what my .screenrc looks like:

attrcolor b ".I"
termcapinfo xterm 'Co#256:AB=\E[48;5;%dm:AF=\E[38;5;%dm'
defbce "on"
term screen-256color-bce
share|improve this question

migrated from stackoverflow.com Oct 3 '11 at 11:51

This question came from our site for professional and enthusiast programmers.

up vote 13 down vote accepted

add set bell-style none to the readline init file, ~/.inputrc

bell-style

Controls what happens when Readline wants to ring the terminal bell. If set to ‘none’, Readline never rings the bell. If set to ‘visible’, Readline uses a visible bell if one is available. If set to ‘audible’ (the default), Readline attempts to ring the terminal's bell.the terminal's bell.

http://www.gnu.org/software/bash/manual/bashref.html#Readline-Init-File

[edit: thanks Fedyashev Nikita]

share|improve this answer
2  
I had the same problem but the only difference is that Readline init file is stored in ~/.inputrc file(at least in Ubuntu). So I've added it there and now it works fine! thank you – Fedyashev Nikita May 29 '10 at 19:57
    
Using debian, I set this option in /etc/inputrc – Stphane Feb 19 at 0:25

Just add vbell "off" to your .screenrc

share|improve this answer
1  
+1, prefer this method. I just want to turn the visual bell off completely. It's pretty annoying... – hopia Jul 8 '11 at 21:30

The shell "prints" the bell character when it asks "Display all possibilities?" Normally this would beep but something is translating it to a screen flash.

As a wild guess, try changing the termcapinfo line to

termcapinfo xterm 'Co#256:AF=\E[38;5;%dm'

That removes the AB section, which I think means "audio bell".

share|improve this answer

I tried the above solution myself which didn't work.

However, the following solution from Thr4wn worked. http://www.linuxquestions.org/questions/linux-software-2/trying-to-use-gnu-screen-backspace-makes-screen-flash-685321/

The feature is called "visual bell".

here are applicable properties you can set in your ~/.screenrc file

vbell_msg "bell: window ~%" # Message for visual bell
vbellwait 2 # Seconds to pause the screen for visual bell
vbell off # Turns visual bell off

[edit] Forgot to say that the last line seems to be all it needs.

share|improve this answer

The sequence Ctrl-a, Ctrl-g is quick way to toggle the "visual bell" in screen.

share|improve this answer
1  
It says "switched to audible bell." when you do this. I wonder if the server beeps whenever I hit <tab> too many times. Maybe I will practice my Morse code and see if anyone responds. – nobar Nov 5 '15 at 22:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.