Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I can connect to the server using my OS X Lion client with my username/password on OpenIndiana. However I do not have permissions to see the share contents, just mount it.

Permissions are user:staff 755 with no complex acls for the entire tree on the server.

If I go through terminal, i can see inside the share just fine at /Volumes/MyShare, so its only finder that is having an issue. Any ideas?

Help me SuperUser, you're my only hope!

Edit: In fact, its this issue exactly https://discussions.apple.com/thread/3193429?start=0&tstart=0

share|improve this question
1  
are you able to try to connect with other clients (older OS X, windows, linux)? I'm asking because the whole smb is renewed in lion, it isn't anymore based on samba - perhaps there are some compatibility problems –  guenter Oct 3 '11 at 14:55
    
I've updated the question, it seems this is specifically a problem with finder somehow –  Joshua Hogendorn Oct 5 '11 at 6:19

2 Answers 2

up vote 2 down vote accepted

I'm quite sure it's a Finder issue. Indeed, you can access your share using a terminal or another file manager. To use Finder, you can try the solution reported here and here.

It is a temporary fix, but it works as in any previous versions of OSX (i.e. it survives the sleep mode etc.). I recap the solution here for the sake of documentation.

Mount CISF/SMB in "Findable" way:

  1. Mount the share using Finder (e.g.cmd+K)
  2. Close the Finder window
  3. Turn off the network connection (eth/WiFi etc.)
  4. Open a Terminal:
  5. Run the command: open /Volumes/$sharename
  6. Restart the connection
  7. Open again the share with Finder and it should work as expected.
share|improve this answer
1  
illumos.org/issues/1718 tracks the change to the illumos kernel (which OI uses) to workaround this problem. (Contributed by the Nexenta engineers working on the problem linked to in your answer.) –  alanc Nov 18 '11 at 3:29

The fix I originally implemented for this was to switch to using AFP. The answer above probably works though.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.