Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using Chrome, Internet Explorer, and Mozilla Firefox. None of them can access Facebook. I keep getting this error from all browsers that I use:

You are using an incompatible web browse

How do I correct it?

I have searched the open questions, but have not found a specific answer to my question, or a simple answer to my question.

share|improve this question

closed as too localized by Sathya Jun 8 '12 at 5:45

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
What browsers are you using? What sites are you going to? –  Jin Oct 3 '11 at 17:05
    
It is impossible to answer this question without the info @Jin has requested, so I'll second that. Please edit your question to contain this information. –  Shinrai Oct 3 '11 at 17:07
1  
I am using Chrome, Explorer, and Mozilla. None of them can access Facebook. –  momarcellus Oct 3 '11 at 17:08
3  
What does this website return? whatsmyuseragent.com –  slhck Oct 3 '11 at 17:19
2  
Have you tried accessing it with all firewalls and internet security programs disabled? –  Ƭᴇcʜιᴇ007 Oct 3 '11 at 17:25

4 Answers 4

I have struggled with this one for a long time, tried dozens of things that were suggested by others, and finally cracked it this morning! I have Symantec Endpoint Protection installed. I had to go to Network Threat Protection -> Options -> Change Settings and under Stealth Settings, remove checks from all 3 boxes.

What's important is that this seems to be a case of your firewall, whatever kind you are running, trying to protect you from some transaction that is required by Facebook, so if you have a different firewall than Symantec Endpoint, look for some setting that might be filtering out what Facebook needs.

It is unfortunate that Facebook gives this very misleading error message under these conditions! Symantec, at least, does warn you in the Settings box that enabling these settings may interfere with using some websites.

share|improve this answer

Since it's affecting all 3 browsers, it's not likely a browser problem. One issue that can cause this is security software blocking web sites from being able to detect your browser or operating system.

In Symantec and Norton security software, you need to disable "stealth" mode. Here's a link which explains "Stealth Mode" and why it will cause this behavior:

http://www.symantec.com/business/support/index?page=content&id=TECH103309

Which security software are you using? Others may have a similar setting. Try changing whatever setting allows web sites to detect your operating system and browser version.

Also try disabling any web filtering software, if you have any installed.

share|improve this answer

Set a user agent:

httpRequest.UserAgent =
  "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.2; .NET CLR 1.0.3705;)"
share|improve this answer

Do have read of this article facebook-incompatible-web-browser . In most cases your firewall or security software could be causing the problem. Corrupt user agent could also be the reason.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.