Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Is there a registry setting I can change to apply this fix from http://support.microsoft.com/default.aspx?scid=303846?

You can disable blank password restrictions by using a policy. To locate and change this policy: Click Start, point to Run, type gpedit.msc, and then click OK to start the Group Policy Editor. Open Computer Configuration\Windows Settings\Security Settings\Local Policies\Security Options\Accounts: Limit local account use of blank passwords to console logon only. Double-click Limit local account use of blank passwords to consol logon only. Click Disabled, and then click OK. Quit Group Policy Editor.

I want to Run As to a different user with a blank password, but I can't. I get this message a lot with remote access too. How can I change it in Home Premium?

(I just saw this but the setting's not in the list.)

share|improve this question
    
I think you need to state the specific problem you are trying to solve and all the OSs involved. –  Moab Oct 4 '11 at 1:10
    
@Moab: I want to run a program as a different user, a user who doesn't have a password, on Windows 7 Home Premium. Thanks for the answer, I'll try it soon. –  minitech Oct 4 '11 at 15:43
add comment

1 Answer

up vote 9 down vote accepted

I found this, it may be for XP but suggestion to use regshot on a Pro Windows 7 PC to capture the registry change may solve it for you

Take a look at this registry key which may disable it. I believe when set to zero as shown.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\limitblankpassworduse:
0x00000000

I use a free program called Regshot to do comparisons of the registry before and after such a change. There are other programs that may be a bit easier to use but for the price and the fact that it does not have to be installed make Regshot a neat utility to have.

http://www.snapfiles.com/get/regshot.html --- Regshot.

Source of Information

I checked my Windows 7 Pro gpedit, that group policy location does not exist, they must have changed it in Windows 7 for security reasons.

share|improve this answer
    
Works perfectly, thanks! –  minitech Oct 6 '11 at 4:06
    
That's good news, so it was the registry hack? –  Moab Oct 6 '11 at 14:48
    
Yes, it was the registry hack. Good thing it still exists. (Now I have the added bonus of a computer-universal iTunes, too!) –  minitech Oct 6 '11 at 17:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.