Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I know this is some kind of setting issue but I can't remember how to resolve it. Basically I'm SSH'ing into a remote machine (Ubuntu) and short cuts such as up, history, tab etc. do not work.

Can anyone tell me what I need to change either on my machine (Mac) or remotely so everything works!

share|improve this question
1  
What is the shell of the Ubuntu machine? –  Jin Oct 4 '11 at 7:35
    
I'm assuming its bash –  stevo Oct 6 '11 at 8:25
add comment

1 Answer

up vote 3 down vote accepted

Bash comes with completion and history enabled by default. See your ~/.bashrc and/etc/bash.bashrc. The Ubuntu machine might be using /bin/sh instead of /bin/bash. $ chsh -s /bin/bash should do the trick.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.