Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to run grep (cygwin) within Xemacs 21.4.22 on windows 7 enterprise laptop.

cd c:\
grep -n -r --include=*.java "foo" NUL:
grep: NUL:: No such file or directory

grep exited abnormally with code 2 at Tue Oct 04 12:53:15
cd c:\
grep -n -r --include=*.java "foo" * NUL:
grep: NUL:: No such file or directory

grep exited abnormally with code 2 at Tue Oct 04 12:56:55
c:\>grep --version
GNU grep 2.6.3

Copyright (C) 2009 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

What am I doing wrong? How can I fix this?

Assuming that Xemacs was wrong, I tried it on emacs 23.2.1 (mingw) on the same laptop and it is getting the same error response.

share|improve this question
    
Why do you put NUL: in that line? –  Mat Oct 4 '11 at 8:24
    
I am not putting NUL. emacs/xemacs is automatically appending that to whatever I type. –  anjanbacchu Oct 4 '11 at 9:00

1 Answer 1

This problem is discussed, with several possible solutions, at EmacsWiki http://www.emacswiki.org/emacs/NTEmacsWithCygwin. I don't have your exact setup here - so you would have to try the options there to see what works.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.