Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I finally decided that I would update my desktop from Windows Vista SP2 64-bit to Windows 7 64-bit. So I got my Windows 7 Professional 64-bit DVD, popped it into my PC, and started up the installer and told it to upgrade.

The installer told me that some things may not be compatible with the upgrade, so I cancelled the install and ran the Upgrade Advisor. I uninstalled the programs and removed the drivers it said were incompatible.

The upgrade got to the final step (restoring settings); it got to 92%, but I didn't feel like staring it anymore so I left the room. When I came back, it had rebooted back into Vista with a note saying "Sorry, the upgrade failed."

I Googled a bit and found people had luck after uninstalling things like Wireshark and the ATI drivers. Did that, tried again, still rolled back.

I looked in the logs, specifically C:\$WINDOWS.~BT\Sources\Panther\setupapi\, and found the following line. (Each time I try to upgrade the Device in this line is different. This is the most recent log entry, I didn't save the older ones.)

!    cci: !NCI: Op=BIND, Layer=NDIS, Upper=Tcpip6 Lower=\Device\{9A2D9804-A610-4D0B-8B8B-392406EE148F}, Error=00000019

I figured this was a problem with my network devices, so I uninstalled everything (from device manager) except my ethernet port and the WAN Miniports (I can't remove them, when I uninstall them from device manager, nothing happens). I also unchecked IPv6 in my network card's property page.

This still didn't help, it still rolled back after I tried to upgrade.

I know I can (read: should) do a clean install, but I want to get this upgrade to work. Does anyone have any ideas on how to make this upgrade work? I have my graphics card (ATI) drivers uninstalled, all USB things unplugged, all network devices (except my ethernet port and WAN Miniports) uninstalled, all programs the Windows Upgrade Advisor told me to uninstall uninstalled. What could be causing Windows to fail to upgrade and roll back to Vista?

P.S. Just now I found a list of all the Windows 7 upgrade log files:

P.P.S. Here is a copy of my C:\$WINDOWS.~BT\sources\Rollback\setuperr.log (which oddly isn't on Microsoft's list of log files):

EDIT: I took at look at C:\$WINDOWS.~BT\Sources\Panther\setuperr.log and found this:

2011-10-03 22:19:03, Error      [0x080a97] MIG    HKLM\Software\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Drivers32 [msacm.l3codecp] is not a valid registry value[gle=0x00000002]
2011-10-03 22:19:25, Error      [0x0808fe] MIG    Plugin {e0cbf06c-cd8b-4647-bb8a-263b43f0f974}: BthMig: Failed to migrate bthport keys, bailing out

Some basic Googling found this thread on Microsoft's forums, maybe it'll help (see page 2). I'm going to try setting MIG_UPGRADE_IGNORE_PLUGINS to bthmigplugin.dll, let's see what happens.

EDIT 2: Here is the full contents of C:\$WINDOWS.~BT\Sources\Panther\setuperr.log (after running the upgrade with MIG_UPGRADE_IGNORE_PLUGINS set to bthmigplugin.dll):

2011-10-04 23:24:18, Error                        Failed to find driver file path. Error=00000002x[gle=0x80092004]

Edit 3: I found another SU thread: and as it suggested, installed WinDBG. I did not have C:\$WINDOWS.~BT\Sources\setupmem.dmp, but I did have C:\$WINDOWS.~BT\Sources\Panther\setupmem.dmp. I opened it up in WinDBG, and it said (Full output:

The Winlogon process terminated unexpectedly.
Arg1: fffff8a001f916c0, String that identifies the problem.
Arg2: 0000000000000001, Error Code.
Arg3: ffffffffc0000001
Arg4: 0000000000110bd8

Edit 4: I posted this on Microsoft's forums too: link.

Now we may be getting somewhere!

Edit 5: I looked in C:\$WINDOWS.~BT\Sources\Panther\setupact.log, which is a 136 MB log file, and I found something actually useful.

2011-10-10 21:20:34, Info                         [NdisCompl: Enter HrGetComponentID]
2011-10-10 21:20:34, Info                         ComponentID=ms_netbt_smb
2011-10-10 21:20:34, Info                         [NdisCompl: Exit HrGetComponentID]
2011-10-10 21:20:34, Info                         [NdisCompl: Enter HrGetComponentDriverFilePath]
2011-10-10 21:20:34, Error                        Failed to find driver file path. Error=00000002x[gle=0x80092004]
2011-10-10 21:20:34, Info                         [NdisCompl: Exit HrGetComponentDriverFilePath]

2011-10-10 21:20:35, Info                         [NdisCompl: Enter HrGetComponentID]
2011-10-10 21:20:35, Info                         ComponentID=ms_rasman
2011-10-10 21:20:35, Info                         [NdisCompl: Exit HrGetComponentID]
2011-10-10 21:20:35, Info                         [NdisCompl: Enter HrGetComponentDriverFilePath]
2011-10-10 21:20:35, Info                         ServiceName = RasMan
2011-10-10 21:20:35, Info                         FilePathLen = 56
2011-10-10 21:20:35, Info                         FilePath = C:\Windows\%SystemRoot%\system32\svchost.exe -k netsvcs
2011-10-10 21:20:35, Info                         Service Binary C:\Windows\%SystemRoot%\system32\svchost.exe -k netsvcs, is not a driver file
2011-10-10 21:20:35, Error                        Failed to find driver file path. Error=ffffffffx[gle=0x00000003]
2011-10-10 21:20:35, Info                         [NdisCompl: Exit HrGetComponentDriverFilePath]

I tried to do netcfg -e -u ms_netbt_smb and netcfg -e -u ms_rasman, but nothing happened.

C:\Users\NTICompass>netcfg -e -u ms_netbt_smb
Trying to uninstall ms_netbt_smb ...


C:\Users\NTICompass>netcfg -e -u ms_netbt_smb
Trying to uninstall ms_netbt_smb ...



It doesn't seem to want to uninstall. How do I uninstall ms_netbt_smb and ms_rasman?

Edit 6: I removed ms_netbt_smb and ms_rasman by looking through the registry and removing keys that referenced them. Now my setuperr.log is blank, and I'm still getting the cci: !NCI: Op=BIND, Layer=NDIS, Upper=Tcpip6 error. I asked that as a separate question: Upgrade to Windows 7 Rolls Back To Vista, as this one is getting kind of long and messy.

share|improve this question
Windows Vista SP2 64-bit is this also Professional? – N4TKD Oct 4 '11 at 14:41
@JohnDR: It's actually Windows Vista Enterprise (64-bit, SP2), but I changed EditionID and ProductName in HKLM\Software\Microsoft\Windows NT\CurrentVersion from "Enterprise" to "Business". As a test, I did a fresh install of Vista Enterprise in VirtualBox, changed those keys to "Business" and tried to upgrade to 7. That worked. – Rocket Hazmat Oct 4 '11 at 14:54
@Rocket - You also updated the virtual machine to SP2 right? Otherwise your test wasn't accurate. – Ramhound Oct 4 '11 at 15:29
@Ramhound: I'm 80% sure the Windows Vista Enterprise ISO I used was SP2. Would SP2 cause problems with upgrading to Windows 7? – Rocket Hazmat Oct 4 '11 at 15:36
@Ramhound: My real machine has the Platform Update, which the VM didn't have. – Rocket Hazmat Oct 4 '11 at 16:40
up vote 0 down vote accepted

The differences between Vista and Windows 7 are rather minimal, using the same driver architecture, so the upgrade/downgrade should have worked.

It is of course possible that, as sometimes happens, upgrading your computer is impossible without a fresh install, but it is also possible that the conversion of Enterprise to Professional caused the problem.

Downgrade from Enterprise to Professional is not officially supported, but is possible through the registry hacks, as you did.

However, since you have a 64-bit version, the changes must be done in two registry keys:
HKLM\Software\Microsoft\Windows NT\CurrentVersion\
HKLM\Software\Wow6432Node\Microsoft\Windows NT\CurrentVersion.

As 64-bit Windows is really a mashup of 32-bit and 64-bit code, the problems could have arrived because only the 64-bit could be updated, as you have not hacked the registry key for 32-bit.

For more info see the article Downgrade (Upgrade) Windows 7 Enterprise to Ultimate, Professional or Home Premium, which also proposes the Windows 7 Downgrader tool to do the job.

I suggest that you try to restore, if possible, Vista to a time before you started hacking, then use the Downgrader tool, reboot cleanly, check the above registry keys, and if everything is well try again the upgrade.

Try the Downgrader tool before trying the upgrade again, even if you cannot restore back the registry.

share|improve this answer
The weird thing is, I made a VM of Vista Enterprise 64-bit, I only changed the version string in HKLM\Software\Microsoft\Windows NT\CurrentVersion, and the upgrade to 7 Professional worked. I think it's a driver issue, but yeah, most Vista drivers should just work on 7. It's error is Failed to find driver file path., wish I knew which driver it's referring to. – Rocket Hazmat Oct 7 '11 at 15:16
Did you try the Downgrader tool ? You could also try "sfc /scannow" in Vista to make sure everything is ok (need installation CD of same service pack as installed). – harrymc Oct 7 '11 at 15:46
I'll give the Downgrader tool a shot, also sfc /scannow may help, didn't think of that. – Rocket Hazmat Oct 7 '11 at 15:55

Run the Windows 7 upgrade advisor, see if it flags any software or drivers, remove what is suggests before upgrading.


Here are the causes of the 21a error

Mismatched system files have been installed.

A Service Pack installation has failed.

A backup program that is used to restore a hard disk did not correctly restore files that may have been in use.

An incompatible third-party program has been installed.

Source (not for Vista or W7 but may help diagnose)


share|improve this answer
I did that. It suggested I remove GIMP, .NET framework 1.1, and a few other things. It suggested I remove a few drivers too. I remove all the things it said, but no dice. It did say that Steam may not be compatible (which it obviously is), but I left that installed (no way am I re-installing all my games). I doubt this is Steam's fault. When I ran the upgrade, it told me that I should remove the ATI control center and install manager. I removed all ATI drivers, but it's still telling me I should remove the install manager (thought I did). Though I doubt that's the issue either. – Rocket Hazmat Oct 4 '11 at 16:37
Perform a clean boot and try upgrading… – Moab Oct 4 '11 at 17:03
Tried a clean boot, then the upgrade. Didn't help :-( – Rocket Hazmat Oct 5 '11 at 15:44
What about using Windows' built-in "Administrator" account? – Rocket Hazmat Oct 5 '11 at 20:14
Check my edit to my answer – Moab Oct 5 '11 at 20:20

Upgrading from Vista to Windows 7 is like upgrading from Windows ME to Windows XP. It's possible and 1/100 may have some luck but still doesn't make it a good idea. I'd say, back up your data, format and do a fresh install.

Edited to make Ramhound happy.

EDITED: A rollback may also occur when the third-party driver Sptd.sys is installed on the computer. This driver is distributed with several applications such as Daemon Tools and Alcohol 120%. You can temporarily uninstall third-party CD/DVD Authoring or Virtualization software that could contain this driver before you upgrade the computer to Windows 7.

share|improve this answer
Yeah, I know that's what I should do, but why on earth does Microsoft even allow upgrades if they don't work? P.S. My Windows ME to Windows XP upgrade actually worked (guess I've used up my Windows Upgrade quota) :-) – Rocket Hazmat Oct 5 '11 at 16:07
Only possible sensitive answer. – gd1 Oct 11 '11 at 12:28
This is a horrible answer. I have see hundreds of computers been upgraded from Vista to Windows 7 without a single problem. – Ramhound Oct 11 '11 at 13:52
You may be right Ramhound, but obviously it's not successful for everyone. The hundreds of computers that you speak of may all be similar in the sense that they do not have the conflicting driver/hardware. I've never had issues with my computers with upgrading, but I do understand that many people will go several years without maintaining their hardware/software and can/will lead to failed upgrades. – kobaltz Oct 11 '11 at 15:26
Sptd.sys? I /may/ have a third-party one installed, but the errors in the logs don't mention it, so I'm assuming that's not an issue. – Rocket Hazmat Oct 11 '11 at 16:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .