Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Ubuntu keeps detecting my keyboard layout as Romanian. It almost always does this on a reboot and some times on waking from sleep. Some times it just randomly changes back to Romanian while the computer is on. I always set it back to "USA" in the keyboard preferences and delete the Romanian layout. What files configure this in Ubuntu? I looked in xorg.conf and did not find any keyboard settings. How can I set this to USA permanently?

I have a laptop with a typical US layout built in keyboard and I also have an apple keyboard that is also US layout connected via USB. I have run other distributions on this same setup before and never had this happen.

share|improve this question

1 Answer 1

Using the graphical Desktop you may choose System->Preferences->Keyboard and select your layout there.

Using the terminal sudo dpkg-reconfigure console-data should do the trick.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.