Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have installed Ubuntu (Ubuntu 2.6.38-11-generic-pae #50-Ubuntu SMP, i686 Athlon i386 GNU/Linux). I am newcomer in Linux.

I am trying to install VLC media player using command line:

% sudo apt-get update
% sudo apt-get install vlc vlc-plugin-pulse mozilla-plugin-vlc

The first command is executed without problems. Then I tried to run the second line, which gives me following output:

Reading package lists... Done Building dependency tree        Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies:  mozilla-plugin-vlc : Depends: vlc-nox (= 1.1.9-1ubuntu1.3) but it is not going to be installed  vlc : Depends: vlc-nox (= 1.1.9-1ubuntu1.3) but it is not going to be installed
       Depends: libavcodec52 (>= 4:0.6-1~) but it is not going to be installed or
                libavcodec-extra-52 (>= 4:0.6-1~) but it is not going to be installed
       Depends: libqtgui4 (>= 4:4.5.3) but it is not going to be installed
       Depends: libva-x11-1 but it is not installable
       Depends: libva1 but it is not installable
       Depends: libxcb-keysyms1 (>= 0.3.6) but it is not installable
       Depends: libxcb-randr0 (>= 1.1) but it is not installable
       Depends: libxcb-xv0 (>= 1.2) but it is not installable
       Recommends: vlc-plugin-notify (= 1.1.9-1ubuntu1.3) but it is not going to be installed  vlc-plugin-pulse : Depends: vlc-nox (=
1.1.9-1ubuntu1.3) but it is not going to be installed E: Broken packages

How can I resolve this issue?

After that I also tried to install GNOME Media Player from Ubuntu software center. It returned following error message:

The following packages have unmet dependencies:

gnome-media-player: Depends: libatkmm-1.6-1 (>= 2.22.0) but 2.22.5-0ubuntu1 is to be installed
                    Depends: libc6 (>= 2.4) but 2.13-0ubuntu13 is to be installed
                    Depends: libdbus-1-3 (>= 1.0.2) but 1.4.6-1ubuntu6.1 is to be installed
                    Depends: libdbus-glib-1-2 (>= 0.78) but 0.92-0ubuntu1 is to be installed
                    Depends: libgcc1 (>= 1:4.1.1) but 1:4.5.2-8ubuntu4 is to be installed
                    Depends: libgconf2-4 (>= 2.31.1) but 2.32.2-0ubuntu2 is to be installed
                    Depends: libglib2.0-0 (>= 2.12.0) but 2.28.6-0ubuntu1 is to be installed
                    Depends: libglibmm-2.4-1c2a (>= 2.27.3) but 2.28.0-1 is to be installed
                    Depends: libgstreamer-plugins-base0.10-0 (>= 0.10.0) but 0.10.32-1ubuntu5 is to be installed
                    Depends: libgstreamer0.10-0 (>= 0.10.7) but 0.10.32-3ubuntu3.1 is to be installed
                    Depends: libgtk2.0-0 (>= 2.12.0) but 2.24.4-0ubuntu2 is to be installed
                    Depends: libgtkmm-2.4-1c2a (>= 1:2.22.0) but 1:2.24.0-0ubuntu1 is to be installed
                    Depends: libsigc++-2.0-0c2a (>= 2.0.2) but 2.2.4.2-1ubuntu1 is to be installed
                    Depends: libstdc++6 (>= 4.5) but 4.5.2-8ubuntu4 is to be installed
                    Depends: libunique-1.0-0 (>= 1.0.0) but 1.1.6-1.1ubuntu2 is to be installed
                    Depends: libvlc5 (>= 1.1.0) but 1.1.9-1ubuntu1.3 is to be installed
                    Depends: libxine1 (>= 1.1.8-1) but it is not going to be installed
share|improve this question
    
looks like a great mess... What Ubuntu version are you running (cat /etc/issue)? You might try 'apt-get check' to chech the consistency of the packaging system. –  guenter Oct 4 '11 at 15:56

4 Answers 4

up vote 2 down vote accepted

The logs there are telling you that you're missing a bunch of dependencies. You can go the slow route of installing each one individually or separated by a space. However, I'm running ubuntu 11.04 (latest stable version) and have not experienced the same issues. Only difference could be that I did (below) after a new install.

sudo apt-get update && sudo apt-get upgrade && sudo apt-get install build-essential

enter image description here

When I go to install vlc

sudo apt-get install vlc

It tells me that I need to install dependencies. I type Y to install them. The process goes through normally and installs.

share|improve this answer
    
thanks .... now i can able to install vlc player...I gone for upper answer too.After doing both i am able to install vlc player now. –  prakash.panjwani Oct 4 '11 at 16:44
    
Yeah you know you don't need Ubuntu 11 to install VLC. –  micke Oct 4 '11 at 20:48
    
I know. I was just illustrating and documenting with the version that I had. –  kobaltz Oct 4 '11 at 20:53

Some of the packages, like gstreamer, are not in the standard repository. You need to enable download from multiverse and universe repos.

Software soruces window

More info on: https://help.ubuntu.com/community/Repositories/Ubuntu

share|improve this answer

For me (Ubuntu 11.10) the answer was as simple as running :

 sudo apt-get -f install
share|improve this answer

I also faced same problem. To resolve this I did

Open software center.

From edit click on software source

Under Ubuntu Software tab, enable all the repositories except source code and click on download from

Select other from download drop down

Now click on select best server

Once Ubuntu select best server for you click on chose server

Now click on other software tab.

Remove any entry if you found for VLC. And click on close.

Press ALT + CTRL+T key combination to open the terminal and run following command

sudo apt-get clean
sudo apt-get -f install
sudo apt-get update
sudo apt-get upgrade

After upgrading reboot the system.

After reboot try again to install VLC. Run following commands

sudo add-apt-repository ppa:videolan/stable-daily
sudo apt-get update
sudo apt-get install vlc

Source : - http://computernetworkingnotes.com/ubuntu-12-04-tips-and-tricks/how-to-install-vlc-in-ubuntu.html

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.