Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently purchased a Radeon HD 5450 for my HTPC. When I hook it up to my TV, Windows 7 reports that the audio device only supports 2 channels. Why is this?

I've read that this will happen if the device it is hooked up to doesn't support 5 channels, but there is an Xbox 360 and PS3 hooked up to the TV as well, and they work just fine in 5.1 surround. The TV is also set to use the external audio device which is a surround sound system via Optical audio.

Why would only Windows say the TV only supports 2 channels, and how can I get the system to understand that the TV does support 5 channel audio?

share|improve this question
    
You may want to check that you have the latest drivers/software for your sound card, video card, and chipset. –  kobaltz Oct 4 '11 at 15:52
    
I updated the drivers for the graphics card yesterday, but I haven't checked for updated chipset drivers for the motherboard yet. I have no external sound card. Just the integrated one and the one in the graphics card. –  Crazydog Oct 4 '11 at 16:38
    
Finally got around to updating the chipset drivers. No luck, still 2ch max... –  Crazydog Oct 16 '11 at 23:32

2 Answers 2

I found this thread with some people having the same issue as you described.

http://forums.amd.com/game/messageview.cfm?catid=260&threadid=110508

I recently bought an HD 4670 with HDMI out for my HTPC setup. I was having the same issue as you, but after much trial and error, finally found a fix.

Uninstall the Realtek auido driver.

Restart your PC.

Allow windows to auto-install the basic Windows HDMI driver.

Now download the following ATI Audio driver:

http://support.amd.com/us/gpudownload/windows/pages/hdmi_xp.aspx?⟨=English

Download the ATI HDMI Audio Driver 9.2. Don't worry about the Microsoft one since Vista will have already done that for you.

I know that it says that it's for XP, but it works great in Vista. Install it, restart again.

Now go into the Sound Manger in Control Panel. Under the playback tab right click on the HDMI device, and select "Configure Speakers"

From there you should see the option for 5.1 sourround sound.

share|improve this answer
    
I could not get this to work - Windows would not accept the XP drivers, neither 32-bit nor 64-bit (I'm running x64). –  Crazydog Oct 4 '11 at 16:37
    
You can try to right click on the file and select XP compatibility. –  kobaltz Oct 4 '11 at 16:57
    
Well no - I'm trying to install the driver through Device Manager, via the inf, and Windows will not accept the driver. –  Crazydog Oct 4 '11 at 20:06

The PC won't recognize your TV as 5.1 because it is not even using the standard audio a 5.1 your TV is not 5.1.

I had the same problem. The only way to work was to connect the PC directly to the system, so I had to use a optical cable switcher. Which is actually better because even if you force the 5.1 via HDMI, most TVs does not transport the 5.1 to the optical out, just sending the 2.0 and wasting the surround.

So the solution is to use the optical out on the PC if it has, if it doesn't buy an ext. audio card.

share|improve this answer
    
I did at one point buy a USB sound card with optical audio, but it became obsolete, once I switched to using an AV receiver between the computer and TV (now a Projector). –  Crazydog Apr 17 '13 at 23:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.