Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I live in 15 story student accommodation building that only provides wireless internet. My laptop has a built in "Intel(R) WiFi Link 5100 AGN" wireless adapter. I've been observing the following pattern when connecting to the college wireless network:

  • Connect successfully, the network icon in the system tray shows like 2/5 bars for the signal strength. All is working well, speed is like ~2MB/s, skype video calls work flawlessly.
  • About 10 minutes pass and the signal strength seems to get better, eventually it reaches 5/5 bars in the system tray. However the connection speed starts dropping exponentially to like ~200 kB/s or less, it becomes very unstable, skype video is virtually not working and keeps disconnecting every few minutes.
  • I reconnect to the network manually, everything works very well again, strength 2/5, the pattern repeats itself.

My guess is that my network card decides to switch access points after sometime, since it discovers a better signal, but that signal turns out to be worse for some reason. I verified this in part by changing my wifi adapter setting of "roaming aggressiveness" to the weakest. Now the signal stays at 2/5 for a half an hour or more, but eventually it still reaches 5/5 and I have to reset the connection manually. I also noticed that my android phone does not seem to have this problem, it connects to a weak signal, stays with it and works very nice.

So my question is: is it possible to somehow observe the access point migration, i.e. confirm my suspicion and if this is indeed the case, is it possible to force my adapter to work with a specific access point ?

share|improve this question
add comment

1 Answer

up vote 3 down vote accepted

Have you tried scanning around and looking to see if the wireless network that you're using us sharing the same channels as many others. You are probably using the same channel as many other networks which is causing the interruptions as well as slow speeds.

http://www.howtogeek.com/howto/21132/change-your-wi-fi-router-channel-to-optimize-your-wireless-signal/

Check out the link above as I believe (hopefully) this will help you out.

share|improve this answer
    
Yes, you're right, there are 6 APs and the strongest two are on channel 1, which is shared by god knows how many other networks. I found a setting "Ad Hoc Channel 802.11b/g", which I set to 1-11, but that doesn't seem to work, since my card still uses 1. Is there any way to force a particular channel ? i.e. 52 is the initial channel that I pick up and that works well, before switching to 1. That's an n channel, right ? I'm only allowed to chose b/g channels. –  Saulius Valatka Oct 4 '11 at 22:46
    
Drop the saved network connection that you have for the wireless network and reconnect. –  kobaltz Oct 4 '11 at 23:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.