Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I had an issue with my video card not rendering dual monitors correctly so I attempted to remove and reinstall the fglrx drivers. I followed these steps.

FglrxInteferesWithRadeonDriver

sudo /usr/share/ati/fglrx-uninstall.sh  # (if it exists)
sudo apt-get remove --purge fglrx*
sudo apt-get remove --purge xserver-xorg-video-ati xserver-xorg-video-radeon 
sudo apt-get install xserver-xorg-video-ati
sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core
sudo dpkg-reconfigure xserver-xorg

After following the instructions on this page I am left with no video. After boot the screen goes blank and the signal drops to the monitors. How can I get this fixed?

share|improve this question
    
chroot in to your environment from the Ubuntu Live CD, blacklist fglrx in /etc/modules/ go get an Nvidia based card. I hate my 5770 in to the deep reaches of outerspace. I've got it working, but not particularly well. Many Pandas are crying. –  Doc Oct 5 '11 at 1:58
    
I explain chrooting fairly well here - just take your own route after Step 4. –  Doc Oct 5 '11 at 2:00
    
Yeah, thats not an option really, I would rather simply fix this issue. –  Jeremy B. Oct 5 '11 at 2:23
    
Well, if you want to get your machine in to a remotely workable state, then try the first half of my suggestion. –  Doc Oct 5 '11 at 3:48

1 Answer 1

Here's the problem I encountered with my AMD 5870 when I first installed Ubuntu.

I had "PCI-e 16x" selected for video card in my BIOS. When I installed Ubuntu, Ubuntu did not recognize the HD 5870 because the drivers were not downloaded in Ubuntu yet. So, every time I tried to log on to Ubuntu, the monitor went to sleep and the screen went black. Then, I restarted the computer, went to the BIOS, selected "Onboard" for the video card, and then when I finally logged onto Ubuntu, I downloaded the drivers for the 5870 in Ubuntu. After all that was said and done, I went back into BIOS one last time, selected PCI-e 16x, and then Ubuntu finally recognized the 5870.

The problem is, you can't have the DVI/ HDMI cable connected to the monitor -- computer with "PCI-e 16x" selected in BIOS when you have not downloaded the drivers in Ubuntu yet. Use VGA and "Onboard" until you download the drivers. Then go back and enable the graphics card (PCI-e) in BIOS. That is, if you had the same problem I did.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.