Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The gnome-terminal application lets you open multiple tabs. I typically have Vim in one, gdb in another, and so on. Here's a screenshot of my exciting development environment!

gnome-terminal with 3 tabs open

In versions of Gnome prior to Ubuntu 9.04 cycling the currently selected tab didn't wrap around at the edges. If you pressed the "go to next tab to the right" key combination when on the right-most tab (mapped to shift-right here), it did nothing. But in the latest Ubuntu release it wraps irritatingly to the left-most tab. This is pretty confusing and there's no way to disable it. According to the Ubuntu wiki this is a desirable feature.

Any ideas how to disable wrapping using some hidden gconf option or something? I could probably just download the source and patch out the wraparound, but there must be an easier way.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

I RTFM. You can add this:

gtk-keynav-wrap-around = 0

to ~/.gtkrc-2.0 and have tabs not wrap around.

You may have to close and reopen the terminal or wait a while for this to stick, these settings are not updated immediately but seem to be read every now and again.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.