Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

A while back i installed Windows Server 2003 (32-bit), but had IDE mode rather than AHCI set in the BIOS. Predictably just changing the BIOS makes 2003 blue-screen on boot-up, which to my knowledge is due to missing drivers. How can i install these drivers without resorting to a clean install?

My motivation for enabling AHCI is to allow hot-swapping, which to my knowedge SATA can't do in IDE mode.

share|improve this question

1 Answer 1

I found this, it is for Home Server but this OS is based on 2003

Ok, I saw another post (on a different forum) on how to change from ATA to AHCI and I thought I would share. I finally got it it to work yesterday, after many blue screens ( cause I didn't know exactly which driver to choose)

My setup is a poweredge T110. I did the initial install in ATA mode. (For those who don't know, you can go the bios, and set the mode to be IDE, and enable all ports on the machine) This will ensure WHS installs fine.

Once the server installation is complete you will begin the second step. This is changing the driver to the appropriate AHCI driver. You probably want to clone your current hardware profile, so you can go back to it if you blue screen. This is available in the System --> Hardware --> Hardware Profiles. Open device manager, right click on Standard Dual Controller or something similar It will be under the heading IDE/ATAPI controllers. Click install from specific location. Then click "don't search. I will chose the driver to install" The click have disk. Browse to the driver ( You'll need to get this from your manufacturer, in my case dell ) Choose the appropriate driver. In my case there were more than 10 choices, and I with alot of trial and error I found that the Poweredge T110 needs the "PCH SATA AHCI Controller" which is Intel's new Nehalem controller.

Once it is installed, I disabled the second controller (in AHCI mode you need only one driver, in ATA mode, you seem to get two ) It prompted me to reboot. Upon reboot, you need to go into the bios, and change from IDE mode to AHCI. Once the system loads, it will says mode change detected, data loss will occur. In fact, data loss will not occur, I don;t know why they post this warning ( try at your OWN risk though xD ) Type yes to continue (twice i my case as I have two disks ) and the server should boot fine. If you got the wrong driver and it blue screens, go to your saved config, or use F8 for last known good config.

Note that if you have a manufacturer specific ATA controller, you might need to change it back to the standard Microsoft controller before changing it to the AHCI controller. The Microsoft ATA controller allows you to reboot before install which is key.

Source if Information

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.