Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My computer has started to pause and frequently crash. When I say pause, I don't mean everything freezes, as parts of the user interface and some programs are still responsive. My processor load is typically 0 - 1% at these points and the processor temp is normal (45 - 50C).

After a lot of searching on the internet, I've started using Resource Monitor to look at the disk activity. What I noticed during these pauses is that the C: disk activity is at a 100% with but with very little data transferred. All of the file entries gradually disappear and then suddenly start reappearing with very high response times 10,000 - 120,000ms. Then everything springs back to life for a bit. Typical response times during normal operation are in the region of 0 - 2ms.

So I initially thought my primary hard disk is on it's way out. Then I started to backup my girlfriend's iTunes on the old mechanical D: drive to an external hard disk and noticed that that was displaying the same symptoms too. Now I really don't know what's wrong. Could this be a faulty disk controller?

Running chkdsk /r on each disk after the eventual crash doesn't report any bad sectors on either disk. As the primary disk is an SSD I'm not sure if a bad sector is meaningful as I understand they shuffle data around internally for the purposes of wear levelling.

System
OS: Windows 7 Pro 64bit
Processor: i7 2600
Motherboard: ASRock P67 Extreme 4
Graphics: ATI Radeon HD 4870.
C drive: Corsair F120 SSD
D drive: Some ancient Western Digital mechanical hard drive
share|improve this question
    
do a memtest86 , how long after boot do these symptoms appear? and what is the memory and or paging stuff show. for some reason it sounds like your paging to disk? a leakey program or driver? also could be something to do with your SSD type, as that has been reported more often. but sort of rarer with the corsair. run a search with the model name of the SSD and see if others have had a freezing or Bsod issue. then hop over to corsiars forum do a search there of your model. either you will find a lot of people with same problem, or not. –  Psycogeek Oct 5 '11 at 9:18
    
Rather than "high disk response times", don't you mean "long" or "slow"? –  sawdust Oct 5 '11 at 9:22
    
Thanks for the response. In lieu of doing a memtest, I've used the Microsoft memory checker from the boot menu. Ran for a couple of minutes and didn't report any errors. It can happen when very little is happening on the disk. According to resource monitor the disk activity is less than 100K per second and I'd be surprised if I'm paging significantly as the memory usage is reported at 1.5GB out of 8GB RAM. I'll have a check of the Corsair forum. –  Giles Roberts Oct 5 '11 at 9:46
    
@Giles Roberts Do use memtest86 and let it run until it reaches at least 100% (but just to be sure, let it run for several hours). There's a reason why everyone recommends it to be run. –  AndrejaKo Oct 5 '11 at 11:05
    
@Giles Roberts when this happened with your girlfriend's hard drive, was it that drive that this happened to, or the SSD again? –  Breakthrough Oct 5 '11 at 11:16

2 Answers 2

After having the very same issue, I confirm that bad memory can be a cause of high response times. Actually, I got nearly constant response times from one second up to 20 seconds. After replacing the memory, the response time is down to 0 to 50 ms.

share|improve this answer
up vote 0 down vote accepted

After a few more days of this, I also noticed that my Blu-ray drive was exhibiting the same symptoms. So all three of my drives (SSD, mechanical hard disk and optical drive) were exhibiting the same behaviour. Programs that used the disks heavily were more likely to freeze than ones that didn't. Running a longer memory check from the Windows 7 installer boot menu again reported no errors. I tried reinstalling the OS but it got to the point where it just hung while it was loading the installation from the optical drive.

I sent the motherboard back to Ebuyer. Got a partial refund and replaced it with a cheaper Asus Z67 motherboard. System has worked fine since. So as all drives were playing up I'll put it down to a faulty disk controller.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.