Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have made an update to CentOS5.7 and since then I can't access by SSH to the machine. I have disable the Firewall and I have the "sshd" service active.

I got the following when I do this from the local machine(localhost):

$ ssh andre@192.168.229.136
ssh: connect to host 192.168.229.136 port 22: Connection refused

$ ssh andre@192.168.229.136:22
ssh: 192.168.229.136:22 Temporary failure in name resolution

Can someone give me a clue on how to solve this problem?

share|improve this question
up vote 3 down vote accepted

check, if the machine really runs sshd on port 22:

# netstat -4nl | grep ":22"

and if the machine really has the ip 192.168.229.136:

# ifconfig

and if the machine can be pinged from where you want to access it:

# ping 192.168.229.136

your 2nd command is faulty because it means `connect to the machine with the name '192.168.229.136:22' (and since your dns-resolver is not able to map that name to a valid ip you got 'temporary failure in name resolution'). the flag to set the port is '-p'.

share|improve this answer
    
Thanks for your reply. The ssh service was down... Thanks again – André Oct 5 '11 at 11:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .