Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I can't install updates of Adobe Flash Player when Windows is starting.

I have a proxy server, but I have configured the proxy settings in Internet Explorer. The error message I get says:

An error occurred while downloading the installer. Please make sure you are connected to the internet and try again.

share|improve this question

migrated from serverfault.com Oct 5 '11 at 10:57

This question came from our site for professional system and network administrators.

5 Answers 5

Try this direct link:

Then you'll be able to install it manually.

share|improve this answer

If you use an automatic configuration script in your proxy settings, you might be experiencing this problem. If so, please vote on the bug. I don't think Adobe consider it to be important.

If your current version is older than 10.3.183.5, and if you are trying to use the Adobe Updater rather than going to their web site, you might be running into a bug that has already been fixed. Try going to http://www.adobe.com/go/getflashplayer/ and see if that works.

Or, if all else fails, you can download full installers. Although these are provided for distributors they can still be used to install Flash on a single machine.

share|improve this answer

It finally worked. I did a couple of things which i don't know which one was related to it.

  • Disabled Avast Shield Control for 10 minutes - I have Avast Antivirus installed
  • Corrected my time/date settings - My date/time settings were incorrect.
  • Closed Firefox before installing the update.

I just gave it a final try and it worked like a charm

share|improve this answer

Make sure your system date and time are correct. This error will keep occurring if the date and time is incorrect. I simply corrected the date and time and clicked retry, and it worked :)

share|improve this answer

Open Control Panel -> Internet Options -> Connections -> LAN Settings and uncheck Automatically detect settings. This should make installer connect using manual settings instead.

share|improve this answer
    
Why the downvotes? It's a working solution and I'm pretty sure that some frustrated soul will find this very useful. –  lenix Jun 12 '13 at 19:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.