Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I want to install lighttpd with macports, but:

$ sudo port install lighttpd
--->  Computing dependencies for openssl
--->  Building openssl
Error: Target returned: shell command failed (see log for details)
Log for openssl is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_openssl/openssl/main.log
Error: Unable to upgrade port: 1
Error: Unable to execute port: upgrade openssl failed
To report a bug, see <>

The tail of the log says:

:info:build collect2: ld returned 1 exit status
:info:build make[4]: *** [link_a.darwin] Error 1
:info:build make[4]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_openssl/openssl/work/openssl-1.0.0e-i386'
:info:build make[3]: *** [do_darwin-shared] Error 2
:info:build make[3]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_openssl/openssl/work/openssl-1.0.0e-i386'
:info:build make[2]: *** [libcrypto.1.0.0.dylib] Error 2
:info:build make[2]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_openssl/openssl/work/openssl-1.0.0e-i386'
:info:build make[1]: *** [shared] Error 2
:info:build make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_openssl/openssl/work/openssl-1.0.0e-i386/crypto'
:info:build make: *** [build_crypto] Error 1
:info:build make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_openssl/openssl/work/openssl-1.0.0e-i386'
:info:build shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_openssl/openssl/work/openssl-1.0.0e-i386" && /usr/bin/make -w all " returned error 2
:error:build Target returned: shell command failed (see log for details)
:debug:build Backtrace: shell command failed (see log for details)
    while executing
"$procedure $targetname"
:info:build Warning: the following items did not execute (for openssl): org.macports.install org.macports.destroot
:notice:build Log for openssl is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_openssl/openssl/main.log

Any idea how I can upgrade openssl?

share|improve this question
Fixed it with: sudo port clean openssl then sudo port -d install openssl – Richard Oct 5 '11 at 17:54

I highly recommend moving from macports to homebrew, which is better maintained and less problematic regarding dependencies. In addition you never need to use sudo with homebrew:

brew install lighttpd

share|improve this answer


The idea to run away from port is not always a solution to the existing problem.

The -d switch adds a LOT of debugging information to the installation process, so if you don't want to see that, omit the -d switch. But cleaning and reinstalling the failed package worked miracles.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.