Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have OpenSolaris 2009.06 installed as a guest operating system on Virtualbox 3.0.4 under OS X 10.5.8. The VirtualBox guest additions have been installed. All available updates have been applied to both operating systems and VirtualBox.

The audio does not work. No sound heard on boot, the volume control in not active, and I get a "Could not open resource for wrtitng" error when I try to play a sample sound from the sound preferences diaglog.

The VirtualBox audio settings are

Host Driver: CoreAudio
Controller: ICH AC97
share|improve this question
    
We need details for your "Sound" settings under the VM's settings pane. –  caliban Sep 2 '09 at 14:34
    
that's usable under OpenSolaris. See my answer for a possible solution. –  caliban Sep 2 '09 at 15:04
add comment

1 Answer

up vote 1 down vote accepted

Boot the OpenSolaris guest, and add a new driver binding entry:

$ pfexec bash

# update_drv -a -i '"pci8086,2415"' audio810

Now the mixerctl command should be able to find sound hardware, and when you restart the gnome desktop the gnome volume control applet should see the audio hardware, too.

Solution taken from here.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.