Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Last week, I needed to set up a Windows 2008 server. It required Apache Web Server, and I installed WAMP. The thing is: I only used Linux for servers until now, and I'm stuck with this:

I installed WAMP, which contained Apache. Now, if the computer reboots for unexpected reasons, the WAMP server will not start automatically. I tried registering Apache as a service, and/or added it to startup, but this requires a user to be logged in, and of course none of the tricks found on Google worked for the automatic login.

How do you start an app in Windows 2008 without requiring the user to login?

share|improve this question
You've already pursued the correct answer: Running the program as a service. What you need to diagnose is why running it as a service is still failing or not initiating prior to login. – music2myear Oct 5 '11 at 21:00
The startup type of the services should be set to "automatic". If it is and it's still not starting up, there's something else going on. – Force Flow Oct 5 '11 at 22:14
It will most likely be a permissions issue - what user is the apache service set to run as, and what does it run as when you start it after login? – Paul Oct 5 '11 at 22:35
Thx ForceFlow, after I installed it as service I thought it will be executed without any other setting, but it was set to "Manual" – Andrei Stanca Oct 6 '11 at 5:18

Apache, installed from msi, register himself as service under correct credentials (Local System account)

share|improve this answer
No, don't make it LocalSystem, unless you want to let any vulnerability in Apache or whatever you're running under it to own your entire box – Mark Sowul Oct 6 '11 at 0:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .