Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

For some reason, IIS process (W2WP.EXE) is consuming 95-99% CPU at at all times. I'm trying to determine what is going on but I can't see anything obvious. Last time we saw this issue it was because the website was trying to log data to a log file in an infinate loop but I dont see anythig like that now. I have run procmon for 5 minutes but I don't really see anything indicating what the issue might be or what it is doing. Of course, I'm no expert.

How can I determine what a process is doing that is causing it use consume so much CPU?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Can you isolate which web application is causing the problem by turning each off in turn.

If the application is asp.net, you could attach it to a debugger. Or use Jetbrains Profiler.

share|improve this answer
    
There is only one site running, but we cant attach a debugger because it's deployed in release mode. I'll try the profiler and see what i get –  DustinDavis Oct 5 '11 at 22:44
    
have you tried recycling the app pool? does the event viewer give any indication? are you using any logging? –  bryan Oct 5 '11 at 22:45
    
yes but it continues to occur. –  DustinDavis Oct 5 '11 at 22:47
    
this page might help blogs.technet.com/b/marcelofartura/archive/2006/09/15/… –  bryan Oct 5 '11 at 22:50
1  
JetBrains was a big failure, at best it crashed the process. I used ProcExplorer to determine what the issue was and it pointed to something happeneing with .NET so I went ahead and used RedGate Profiler to see wtf was going on and now I'm trying to figure out how to fix it. thanks. –  DustinDavis Oct 6 '11 at 0:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.