Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Samsung phone running Windows Mobile 6.1 and a laptop running Windows 7 with a USB Modem to access the internet and I would like to share the internet between my laptop and my phone. I tried to make Ad Hoc network and I successfully connected to the Ad Hoc network but unfortunately I can't browse the internet or access MSN Messenger on my phone. Does anyone here have an idea as to how I can connect my phone to the internet via my laptop?

share|improve this question

migrated from stackoverflow.com Oct 6 '11 at 3:55

This question came from our site for professional and enthusiast programmers.

2 Answers 2

If your PC and phone are bluetooth enabled then you can do this by:

  1. Plug the phone into the computer via USB, Windows Mobile Device Center should install (if not then you can download it from: http://www.microsoft.com/download/en/details.aspx?id=14) once it is installed set up a sync connection. (you can sync whatever you want)

  2. Connect your phone to your computer via Bluetooth

  3. On your PC go to your Bluetooth settings (just search in the start menu) and go under the COM Ports tab, click "Add..." and select "Incoming" then click okay (note which port was just created) and then okay again on the first dialog.

  4. On your PC go to the Windows Mobile Device Center click Mobile Device Settings then Connection settings (it may take a minute to show the dialog box) select all of the checkboxes, then under "Allow connections to one of the following" select the COM port that you assigned in the last step then select that the computer is connected to the internet.

  5. Go to your phone under sync settings there should be a check box labeled "Allow advanced network functionality" check it.

Test the network connection on your phone if it is working disconnect the USB cable and then test it again (make sure that you are connected to the computer via Bluetooth).

The downside is that every time you want to connect to the internet you have to connect via Bluetooth and you have to be in range and sometimes you even have to tell the phone to sync immediately!

share|improve this answer
    
thanx for editing my post. Sorry about my english. Regarding to your answer: When I connected my phone to the PC the OS assigned the port number 26 as incoming Bluetooth data, and this port doesn't appear in the Connection settings (there was an option called Bluetooth and I chose it), also I tried to find Allow advanced network functionality and can't see it! My phone is Samsung Omnia Windows Mobile 6.1 GT-B7320 which is non-tuched device!. –  user630908 Oct 5 '11 at 21:42
    
No problem with your english, it's just that I had the same problem and could not find an answer anywhere so I changed it a bit so that it will show up in more searches for other people. After a COM port is automatically assigned you need to assign ANOTHER one as per the instructions above and then you will be able to select it. It should be in your sync settings under advanced. –  A.M.K Oct 5 '11 at 22:33

In Windows 7, you can bridge your wi-fi and ethernet connections.

  1. Open the Network and Sharing Center.
  2. Press Change adapter settings.
  3. Hold Ctrl and click the Local Area Connection and the Wireless Network Connection.
  4. Right-click one of the selected entries and select Bridge Connections.

Now anything connected on your wireless connection is essentially on the same network as your ethernet connection. Realise this is a two-way street so take any usual security precautions.

share|improve this answer
    
But my USB Modem shows different netowrk connection than Wireless Connection. –  Adban Oct 6 '11 at 15:45
    
Sorry, I made an assumption your laptop was connected to the internet by a cable, which I see now was stated as otherwise in your question. Bridge the Wireless Network Connection and the USB Modem instead. Then you can connect the phone to the laptop by wi-fi and it should utilise the laptop's USB Modem. –  Hand-E-Food Oct 6 '11 at 21:58
    
By this way I can't see Bridge option! It does not appear! –  Adban Oct 6 '11 at 22:39
    
Bugger. The USB Modem driver might not support this method. :-( –  Hand-E-Food Oct 6 '11 at 23:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.