Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got an interesting problem that I can't quite figure out. I'm using dual Seagate Barracuda Green 2TB drives ( http://www.seagate.com/ww/v/index.jsp?name=st2000dl003-bcuda-green-sata-6gb-2tb-hd&vgnextoid=add6439d45c0b210VgnVCM1000001a48090aRCRD&locale=en-US ) in a RAID-1 setup on Z68 motherboard, Win7 SP1.

The drives are used for storage, so they periodically go to sleep. The trouble is that once they do, they often won't wake up - I get a drive seeking sound, stops, repeats. Eventually it does recover, but something seems wrong.

Easy, I figure one of the drives is dying. I take one drive out of RAID, same thing is happening. I take the other drive out of RAID, again the same behavior.

So, is anyone else running into this issue?

[Update: SMART tests on both drives outside of RAID are saying that everything is a-ok]

share|improve this question
    
Maybe both drives are messed up. A power surge could have done this. Maybe find a SMART diagnostic utility to try to confirm this. I use "GSmartControl" on Ubuntu for this kind of thing. –  Doc Oct 6 '11 at 4:12
    
What length of time are we talking about for its stuttering wakeup, what range of time if the time varies? –  Psycogeek Oct 6 '11 at 8:21
    
Wakeup time is what sounds like 5-10 spins up/seeks. So, about 5-10 seconds. Mind you, it's not that it takes time to resume, it's that the noises the system is making do not sound good. So I'm wondering whether it's this combination of drives and RAID controller that's the issue. –  reljam Oct 6 '11 at 15:20
    
Mine takes ~10seconds, (seems like a lifetime) to fully spin-up and get going. that is why I asked. it does not bother me in the least, I would not have those "long term storage" drives set to go to sleep, if I would need them regularly. I have it sleep only after a full 45-60min of inactivity. Choosing between the harsh spin-up effort and the long term wear on the bearings. Mine does not sound like anything is abnormal, both seagate greens and WD greens. but it is a lot of whirring and head moving –  Psycogeek Oct 7 '11 at 7:07

2 Answers 2

up vote 1 down vote accepted

Green drives were not engineered for Raid arrays, if you want error free raid arrays, use drives designed for raid arrays. Its a TLER timeout issue, non raid engineered drives have a longer timeout built into the drive firmware, and the Raid chips are all designed to tolerate shorter time outs, its a compatibility issue.

Raid has error correction built in, but only allows so much time for correction to happen on the hard drive before it times out, raid enabled hard drives have a shorter timeout so it does not interfere with the raid timeout, so normal desktop drives have longer timeout settings, so when the hard drive is trying to correct an error the raid chip/firmware waits for a specific time and if it gets no response from the hard drive firmware that the error has been corrected it assumes the raid array is now degraded and flags the drive as degraded and a non functional part of the array which prevents further degradation of data on the hard drive.

Most people have few problems most of the time with desktop drives in Raid arrays, but sometimes you do, which I think may be your issue.

You might run the Seagate diagnostics on the drives, it is possible one of them does have a problem and needs to be warrantied.

Bad data cables can also wreak havoc with raid arrays.

You might send Seagate an email asking if there is a firmware update for your specific model

.

share|improve this answer
    
+1 Green Drives are not good. Firmware will unlikley help. Discussed this with Western Digital and they indicate the Green Drive will be a bad choice. Worth running diag but have seen a number of posts elsewhere reporting this as an issue. –  Dave M Oct 6 '11 at 16:03
1  
Raid seems such a waste on a home pc anyway, I use to convert my Western Digital desktop drives using the WD tler tool, worked great, I don't think Seagate ever had such a tool for their drives. –  Moab Oct 6 '11 at 16:11

For Home Desktop drives, WD Red drives have TLER. They are designed for HOME NAS/RAIDs.
For Enterprise, they have the RE4 model.

Also, read online that some seagate drives are known to have random drive issues with RAID.

share|improve this answer
    
Please provide sources and references. –  user 99572 is fine Mar 5 '13 at 21:35
    
ask.adaptec.com/app/answers/detail/a_id/17241/~/… Also tried 4 x Seagate Barracuda 2TB in RAID 0. Same setup on multiple high-end desktop boxes. Even tried switching up the OS thinking it might be some driver issue. All 3 had random issues where the RAID had errors, but the disks still worked. Eventually though, the data got corrupt. Apparently, there are some firmware updates to fix this, but our drives had manufacturer's firmware on them so it was more challenging to update the firmware on the disks. –  Justin F Mar 8 '13 at 18:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.