Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Recently, my netbook's screen started doing something strange. As the screen changed angles (like when opening the screen), sometimes the screen would go black. The backlight would still be on, there would simply be no image.

This got steadily worse, until today it got so bad I decided I should do something about it. Being not afraid of the inside of my netbook, I popped it open and poked around the inside.

The cable that connected the screen did not appear to be loose or snagged anywhere that turning the screen would affect. In fact everything look fine, but the screen still blanked when it was open more than about 90 degrees.

Eventually something did change: The screen stopped coming on at all. The backlight would still be on, just no image. Wiggling the connection to the motherboard that appears to carry both power for the backlight and the data for the screen, I could make it alternate between no backlight, black with backlight, and white with backlight, but no image.

The system boots fine to an external monitor, and this is not a software issue, because it occurs during the boot up sequence. The netbook is a Asus EeePC 1015 PEM. The "warranty void if removed" sticker is long gone, because it was in the way of upgrading the harddrive to an SSD (really Asus? Really?).

I would like to get my screen working again. Any ideas?

share|improve this question
    
I imagine the price of repairs is roughly the same as a new EeePC. –  Hand-E-Food Oct 6 '11 at 6:15
2  
ASUS said that they'd honour the warranty if the sticker for the eee701 was broken, because it was blocking ram upgrades. So it's worth a try if you ask them. –  DanBeale Oct 6 '11 at 6:39
add comment

3 Answers

If it helps: had a similar problem with a Samsung Netbook NC-10, which turned out to be a known problem. On inspection the ribbon cable looked fine, but was faulty. Replaced with a new one ordered online, cost was about £30, now works fine.

share|improve this answer
add comment

It sounds like the cable between the screen and system board itself is damaged in some way - if a cable changes the way it works during wiggling, it often means a wire is loose or a connector is in some way damaged - wiggling means contact is made or broken. Replacing the cable would probably fix the issue.

share|improve this answer
    
Sorry, I should have been more clear. The wiggling was actually moving the connector in the socket. I've updated the original question. –  Mike Cooper Oct 6 '11 at 6:37
    
that might mean an issue with the connector . If the pins on the board look fine, they probably are. You could probably confirm with a multimeter and a continuity tester –  Journeyman Geek Oct 6 '11 at 6:44
    
No, I mean I was removing half the plug from the socket, disconnecting some pins, but not others. Unfortunatly I don't have a continuity tester available right now. I could probably get one, and I would like to, in order to test the cable. –  Mike Cooper Oct 6 '11 at 6:49
add comment

I suggest contacting Asus anyway. If you are within the support period they will be able to give you advice and may even ask you to take a look around inside to check for loose connections and the like.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.