Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm on a virtual machine, and according to this document in the "Cache Storage and Resource Requirements section", if you're on a VPS you should probably limit the threads to two. I am. But before making changes, I checked to see what my settings (via identify -list resource) were:

File        Area      Memory         Map        Disk  Thread        Time
------------------------------------------------------------------------
 768   2.0004GiB   1.5003GiB   4.0009GiB       16EiB       4   unlimited

I then placed this in ~/.magick/policy.xml:

<policymap>
  <policy domain="resource" name="time" value="60"/>
  <policy domain="resource" name="thread" value="2"/>
</policymap>

Then I checked my settings:

File        Area      Memory         Map        Disk  Thread        Time
------------------------------------------------------------------------
 768   2.0004GiB   1.5003GiB   4.0009GiB       16EiB       4          60

Howcome the thread isn't getting modified? I just copied and pasted the settings.

share|improve this question
up vote 1 down vote accepted

If your policy file doesn't seem to work, then you will need to export one of these variables, where 1 is the number of threads:

OMP_NUM_THREADS=1
MAGICK_THREADS=1

I guess ImageMagick doesn't just look at the policy xml. You might want to put this in your bash profile so it'll always be set.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .