Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a new guest install of Debian 6.0.2.1 i386 as a VM in VMware Server 2 Windows XP host. I selected only the "standard System Utilities." After that I installed SSH and VIM. I then changed the repository selection. Finally I ran apt-get update and rebooted the system. After the reboot the network card does not start automatically. To get it to work, I need to log into the console and type: ifconfig eth0 up once done I have full network access until I reboot, and then have to run the command again. After a rebuild, I was able to duplicate the problem. How do I get the network to start automatically?

Extra Info: ifconfig before running the fix only lists the local adapter. eth0 is missing from the output.

etc/network/interfaces

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
address 192.168.1.15
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255
gateway 192.168.1.254

/etc/apt/sources.list

deb http://ftp.us.debian.org/debian/ squeeze main non-free
deb-src http://ftp.us.debian.org/debian/ squeeze main

deb http://security.debian.org/ squeeze/updates main non-free
deb-src http://security.debian.org/ squeeze/updates main

deb http://ftp.us.debian.org/debian/ squeeze-updates main
deb-src http://ftp.us.debian.org/debian/ squeeze-updates main
share|improve this question
    
It is normal that eth0 is missing from ifconfig's output; the command only shows "up" interfaces. (Running ip link or ifconfig -a would list all.) –  grawity Oct 6 '11 at 20:14
    
Also, unrelated to the problem, but IMHO you are configuring way more than necessary. network can safely be dropped -- it was only necessary in Linux 2.0, fifteen years ago. Similar for broadcast, which is automatically determined. –  grawity Oct 6 '11 at 20:16
    
and yes, with -a it lists eth0 as expected. But until I run ifconfig eth0 up the network does not work. Any ideas on how to fix it? –  cwheeler33 Oct 6 '11 at 20:18
    
@grawity: so this is the weirdest thing. I don't see why it would hurt considering the [Debian docs]( debian.org/doc/manuals/debian-reference/…) but I disabled those lines and it works. Should I post a bug report? –  cwheeler33 Oct 6 '11 at 20:33
    
Yes, and do mention the reference page in it. (Since the IP address and netmask are always configured, both network and broadcast can be calculated in just two operations: network = addr & netmask; broadcast = addr | ~netmask; Having them configured explicitly will just result in confusion several weeks later.) –  grawity Oct 6 '11 at 20:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.