Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Something on my new MacBook Air 2011 is eating up the CPU and battery, with 30% User CPU in Activity Monitor, but there is no process listed with high CPU usage. Temperature is also very high. What could be happening?

share|improve this question

3 Answers 3

up vote 1 down vote accepted

Activity Monitor and sampling tools like top do cull processes that have terminated, so it's possible something is spawning lots of short lived processes.

Also, try changing the sample time to see if it's a rounding error. I have seen activity monitor lag RAM changes by 15 to 60 seconds so there could be measurement errors - especially with hyper threading on the new i5/i7 chipsets.

If you really want to dig into this, you might need to fire up Instruments from Xcode. Also, command tools like top, vm_stat, io_stat, and fs_usage.

The dtrace tools are powerful, but might be worse if you don't have long running processes or want to learn the syntax.

share|improve this answer
1  
Yes -- I discovered this was actually LyX's "Instant Preview" feature gone awry, apparently starting up many dvipng processes that were quickly exiting. That's why they were showing up as 0% CPU. Thanks much! I couldn't try the Instruments tip, but will keep this in mind if it happens again. –  David Oct 7 '11 at 3:26

In Activity Monitor, switch to the "All Processes" instead of "My Processes" and see if there are any high-CPU-usage apps there.

share|improve this answer

In Activity monitor, there should be a drop-down menu that in your case probably says "My Processes." Click on that, and select "All Processes." This will show all of the running processes (sometimes, processes that you don't own are grouped under "User"). Alternatively, if the disk activity is high, you might want to try running iosnoop to figure out what your disk is doing that might cause such high disk activity.

share|improve this answer
    
It's already on All Processes. –  David Oct 7 '11 at 0:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.