Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

For some reason, I am not able to copy discs using Windows Media Player: when I tried to I get a message saying that the device is in use, and that I must wait until it is free (which it never is). I have tried disabling/re-enabling through the Device Manager, with the requisite boots, and no such luck.it's as if there is a "semaphore" file some place, but I cannot find it in any of the Media Player options.

Anybody know what is going on? Please fill me in!

Thank you.

share|improve this question
1  
Windows Media Player was written to invoke self-loathing. Use something like (ImgBurn)[imgburn.com/].. If you find your drive is still reported as locked, then you probably have some silly other program keeping it that way, most likely with the sole purpose of antagonizing you. –  Doc Oct 7 '11 at 1:05
1  
yes, Media Player was certainly not written to keep people sane! :-) –  greenber Oct 7 '11 at 1:13
    
Agreed, it has another agenda. –  Doc Oct 7 '11 at 1:17
    
but there has to be some reason for the "device in use" error message! Is my presumption that it is a hidden semaphore file entirely off-base? If so where is the frigging thing? Aargh! –  greenber Oct 7 '11 at 1:18
    
There may be a semaphore involved, but if so, the way to approach it is to find the program that's creating it - and close that program. –  Doc Oct 7 '11 at 1:24

2 Answers 2

Can you burn CDs in Windows Explorer? If not, you may need to try the Filters trick from Microsoft. If you can, then try through WMP again. Try clearing out your burn folder too? Sometimes there can be a stuck file in there

share|improve this answer

I got it to work and I think I know the reason for the problem in the first place: my theory was that there was a semaphore of some sort that disallowed writing to the CD. First, the solution: I had Media Player in my taskbar. Right-click on the Media Player and run as administrator – you need only do this once. From that point onwards Media Player can be run as a normal user.

here's what I think the boys and girls at Microsoft did: have media player run normally. When I attempt to burn a CD, check to see if the device is in use. If it is give the error message and exit burn mode. Otherwise, elevate to admin, write the semaphore,burn the CD, remove the semaphore and de-elevate privileges.

The problem, I think, is if the burn CD process is interrupted: it leaves a "protected" semaphore that can not be removed from a normal process: only from an elevated process. If the semaphore had been written from the non-elevated process then this would not have been a problem.

I think.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.