Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm starting to get really frustrated with Apache2 so hopefully I can get some kind of answer through here and feel a lot better about this whole thing. I've been spending so much time just trying to get it working with just normal configurations that it's driving me crazy.

Anyways.. so the problem is I can't access my website from computers on networks other than the one the server is on. I looked in httpd.conf and in the default settings section I tried changing it from

Order deny, allow 
Deny from all 

to this:

# First, we configure the "default" to be a very restrictive set of 
# features.  
#
<Directory/>
    Options FollowSymLinks
    AllowOverride None
    Order allow, deny
    Allow from all
</Directory>

That's the only thing I changed in the config file and it just broke.. I couldn't even access the site locally anymore. So I changed it back to what it was before and expected it to at least work again locally but it was still broken. I had to resort to using the original config file and change the root folder and add in php module etc... which is annoying. Why would it break just by changing that one line and then still not work after changing it back? Doesn't make sense to me.

Anyhow, after going back to the original config file and changing nothing except for the root folder and adding the php module in, I could then access the site locally again. I tried accessing the website from another computer on the same network to see if that still worked and to my surprise it didn't even though it worked before with the exact same settings in the config file!

Any ideas? Is there something in the config file that I'm not aware of? Thank you for your help.

share|improve this question

migrated from serverfault.com Oct 7 '11 at 10:54

This question came from our site for system and network administrators.

    
netstat --protocol=ip -nlp | grep :80? –  quanta Oct 7 '11 at 7:17

1 Answer 1

Since you mention that this is on a home network do you have port 80 forwarded to the internal server for outside requests? Is there a firewall separating the networks from each other?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.